2.0 beta init
[framework/multimedia/gstreamer0.10.git] / packaging / gstreamer.spec
1 Name:       gstreamer
2 Summary:    GStreamer streaming media framework runtime
3 Version:    0.10.36
4 Release:    2
5 Group:      Applications/Multimedia
6 License:    LGPLv2+
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post): /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10 BuildRequires:  pkgconfig(glib-2.0)
11 BuildRequires:  pkgconfig(libxml-2.0)
12 BuildRequires:  pkgconfig(mm-ta)
13 BuildRequires:  bison
14 BuildRequires:  flex
15
16
17 %description
18 GStreamer is a streaming media framework, based on graphs of filters which
19 operate on media data. Applications using this library can do anything
20 from real-time sound processing to playing videos, and just about anything
21 else media-related.  Its plugin-based architecture means that new data
22 types or processing capabilities can be added simply by installing new 
23 plugins.
24
25
26
27 %package devel
28 Summary:    Development tools for GStreamer
29 Group:      Development/Libraries
30 Requires:   %{name} = %{version}-%{release}
31
32 %description devel
33 This package contains the libraries and includes files necessary to develop
34 applications and plugins for GStreamer. If you plan to develop applications
35 with GStreamer, consider installing the gstreamer-devel-docs package and the
36 documentation packages for any plugins you intend to use.
37
38
39 %package tools
40 Summary:    Common tools and files for GStreamer streaming media framework
41 Group:      Applications/Multimedia
42 Requires:   %{name} = %{version}-%{release}
43
44 %description tools
45 This package contains wrapper scripts for the command-line tools that work
46 with different major/minor versions of GStreamer.
47
48
49
50 %prep
51 %setup -q -n %{name}-%{version}
52
53
54 %build
55
56
57 export CFLAGS+=" -Wall -g -fPIC\
58  -DGST_EXT_AV_RECORDING\
59  -DGST_EXT_QUEUE_ENHANCEMENT\
60  -DGST_EXT_CURRENT_BYTES\
61  -DGST_EXT_MODIFIED_DQBUF"
62
63 %configure --prefix=/usr\
64  --disable-valgrind\
65  --without-check\
66  --disable-static\
67  --disable-rpath\
68  --disable-libtool-lock\
69  --disable-alloc-trace\
70  --disable-gcov\
71  --disable-nls\
72  --disable-examples\
73  --disable-tests\
74  --disable-failing-tests\
75  --disable-docbook\
76  --disable-gtk-doc\
77  --disable-registry-update\
78  --disable-loadsave\
79  --with-html-dir=/tmp/dump
80
81 make %{?jobs:-j%jobs}
82
83 %install
84 rm -rf %{buildroot}
85 %make_install
86
87 rm -rf %{buildroot}/tmp/dump
88
89
90 %post -p /sbin/ldconfig
91
92 %postun -p /sbin/ldconfig
93
94
95
96
97
98
99
100
101
102
103
104 %files
105 %defattr(-,root,root,-)
106 %doc AUTHORS COPYING NEWS README RELEASE TODO
107 %{_libdir}/libgstreamer-0.10.so.*
108 %{_libdir}/libgstbase-0.10.so.*
109 %{_libdir}/libgstcontroller-0.10.so.*
110 %{_libdir}/libgstdataprotocol-0.10.so.*
111 %exclude %{_libdir}/libgstnet-0.10.so.*
112 %{_libdir}/libgstcheck-0.10.so.*
113 %dir %{_libdir}/gstreamer-0.10
114 %{_libdir}/gstreamer-0.10/libgstcoreelements.so
115 %{_libdir}/gstreamer-0.10/libgstcoreindexers.so
116 %dir %{_libexecdir}/gstreamer-0.10
117 %{_libexecdir}/gstreamer-0.10/gst-plugin-scanner
118 %{_bindir}/gst-feedback-0.10
119 %{_bindir}/gst-inspect-0.10
120 %{_bindir}/gst-launch-0.10
121 %{_bindir}/gst-typefind-0.10
122 %{_bindir}/gst-xmlinspect-0.10
123 %doc %{_mandir}/man1/gst-feedback-0.10.*
124 %doc %{_mandir}/man1/gst-inspect-0.10.*
125 %doc %{_mandir}/man1/gst-launch-0.10.*
126 %doc %{_mandir}/man1/gst-typefind-0.10.*
127 %doc %{_mandir}/man1/gst-xmlinspect-0.10.*
128
129
130 %files devel
131 %defattr(-,root,root,-)
132 %dir %{_includedir}/gstreamer-0.10
133 %dir %{_includedir}/gstreamer-0.10/gst
134 %{_includedir}/gstreamer-0.10/gst/*.h
135 %{_includedir}/gstreamer-0.10/gst/base
136 %{_includedir}/gstreamer-0.10/gst/check
137 %{_includedir}/gstreamer-0.10/gst/controller
138 %{_includedir}/gstreamer-0.10/gst/dataprotocol
139 %{_includedir}/gstreamer-0.10/gst/net
140 %{_datadir}/aclocal/gst-element-check-0.10.m4
141 %{_libdir}/libgstreamer-0.10.so
142 %{_libdir}/libgstbase-0.10.so
143 %{_libdir}/libgstcontroller-0.10.so
144 %{_libdir}/libgstdataprotocol-0.10.so
145 %exclude %{_libdir}/libgstnet-0.10.so
146 %{_libdir}/libgstcheck-0.10.so
147 %{_libdir}/pkgconfig/gstreamer-0.10.pc
148 %{_libdir}/pkgconfig/gstreamer-base-0.10.pc
149 %{_libdir}/pkgconfig/gstreamer-controller-0.10.pc
150 %{_libdir}/pkgconfig/gstreamer-check-0.10.pc
151 %{_libdir}/pkgconfig/gstreamer-dataprotocol-0.10.pc
152 %{_libdir}/pkgconfig/gstreamer-net-0.10.pc
153
154 %files tools
155 %defattr(-,root,root,-)
156 %{_bindir}/gst-feedback
157 %{_bindir}/gst-inspect
158 %{_bindir}/gst-launch
159 %{_bindir}/gst-typefind
160 %{_bindir}/gst-xmlinspect
161 #%{_bindir}/gst-xmllaunch
162