Git init
[framework/location/libslp-location.git] / packaging / libslp-location.spec
1
2 Name:       libslp-location
3 Summary:    Location Based Service
4 Version:    0.3.23
5 Release:    2
6 Group:      System/Libraries
7 License:    TBD
8 Source0:    %{name}-%{version}.tar.bz2
9 Requires(post):  /sbin/ldconfig
10 Requires(post):  /usr/bin/vconftool
11 Requires(postun):  /sbin/ldconfig
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(gconf-2.0)
14 BuildRequires:  pkgconfig(dlog)
15 BuildRequires:  pkgconfig(vconf)
16
17 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
18
19 %description
20 Location Based Service Libraries
21
22
23 %package devel
24 Summary:    Location Based Service (Development files)
25 Group:      System/Libraries
26 Requires:   %{name} = %{version}-%{release}
27
28 %description devel
29 Location Based Service Development Package
30
31
32
33 %prep
34 %setup -q -n %{name}-%{version}
35
36
37 %build
38
39 ./autogen.sh
40 ./configure --prefix=%{_prefix} --enable-dlog --enable-debug
41
42 # Call make instruction with smp support
43 make %{?jobs:-j%jobs}
44
45 %install
46 rm -rf %{buildroot}
47 %make_install
48
49
50 %clean
51 rm -rf %{buildroot}
52
53
54
55 %post 
56 /sbin/ldconfig
57 vconftool set -t int db/location/LocationEnabled "1" -g 6514 -f
58 vconftool set -t int db/location/NetworkEnabled "0" -g 6514  -f
59 vconftool set -t int db/location/AgpsEnabled "0" -g 6514 -f
60 vconftool set -t int db/location/SensorEnabled "0" -g 6514 -f
61
62 %postun -p /sbin/ldconfig
63
64
65 %files
66 %{_libdir}/lib*.so.*
67
68
69 %files devel
70 %{_includedir}/location/*.h
71 %{_libdir}/lib*.so
72 %{_libdir}/pkgconfig/*.pc
73