add3f10c8751a7dd1d8dc541412b66e849fce695
[framework/location/libslp-location.git] / packaging / libslp-location.spec
1 Name:       libslp-location
2 Summary:    Location Based Service
3 Version:    0.3.38
4 Release:    1
5 Group:      System/Libraries
6 License:    TBD
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post):  /sbin/ldconfig
9 Requires(post):  /usr/bin/vconftool
10 Requires(postun):  /sbin/ldconfig
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(gconf-2.0)
13 BuildRequires:  pkgconfig(dbus-glib-1)
14 BuildRequires:  pkgconfig(gmodule-2.0)
15 BuildRequires:  pkgconfig(dlog)
16 BuildRequires:  pkgconfig(vconf)
17 BuildRequires:  pkgconfig(location-appman)
18 #BuildRequires:  pkgconfig(json-glib-1.0)
19
20
21 %description
22 Location Based Service Libraries
23
24
25 %package devel
26 Summary:    Location Based Service (Development files)
27 Group:      System/Libraries
28 Requires:   %{name} = %{version}-%{release}
29
30 %description devel
31 Location Based Service Development Package
32
33
34 %prep
35 %setup -q -n %{name}-%{version}
36
37
38 %build
39
40 ./autogen.sh
41 ./configure --prefix=%{_prefix} --enable-dlog --enable-debug
42
43 # Call make instruction with smp support
44 make %{?jobs:-j%jobs}
45
46
47 %install
48 rm -rf %{buildroot}
49 %make_install
50
51
52 %clean
53 rm -rf %{buildroot}
54
55
56 %post
57 /sbin/ldconfig
58 vconftool set -t int db/location/last/gps/Timestamp "0" -f
59 vconftool set -t double db/location/last/gps/Latitude "0.0" -f
60 vconftool set -t double db/location/last/gps/Longitude "0.0" -f
61 vconftool set -t double db/location/last/gps/Altitude "0.0" -f
62 vconftool set -t double db/location/last/gps/HorAccuracy "0.0" -f
63 vconftool set -t double db/location/last/gps/VerAccuracy "0.0" -f
64 vconftool set -t double db/location/last/gps/Speed "0.0" -f
65 vconftool set -t double db/location/last/gps/Direction "0.0" -f
66 vconftool set -t int db/location/last/wps/Timestamp "0" -f
67 vconftool set -t double db/location/last/wps/Latitude "0.0" -f
68 vconftool set -t double db/location/last/wps/Longitude "0.0" -f
69 vconftool set -t double db/location/last/wps/Altitude "0.0" -f
70 vconftool set -t double db/location/last/wps/HorAccuracy "0.0" -f
71 vconftool set -t double db/location/last/wps/Speed "0.0" -f
72 vconftool set -t double db/location/last/wps/Direction "0.0" -f
73 vconftool set -t int db/location/last/cps/Timestamp "0" -f
74 vconftool set -t double db/location/last/cps/Latitude "0.0" -f
75 vconftool set -t double db/location/last/cps/Longitude "0.0" -f
76 vconftool set -t double db/location/last/cps/Altitude "0.0" -f
77 vconftool set -t double db/location/last/cps/HorAccuracy "0.0" -f
78 vconftool set -t int db/location/setting/GpsEnabled "0" -g 6514 -f
79 vconftool set -t int db/location/setting/AgpsEnabled "0" -g 6514 -f
80 vconftool set -t int db/location/setting/NetworkEnabled "0" -g 6514 -f
81 vconftool set -t int db/location/setting/SensorEnabled "0" -g 6514 -f
82
83
84 %postun -p /sbin/ldconfig
85
86
87 %files
88 %{_libdir}/lib*.so*
89
90
91 %files devel
92 %{_includedir}/location/*.h
93 %{_libdir}/pkgconfig/*.pc