upload tizen1.0 source
[framework/location/libslp-location.git] / packaging / libslp-location.spec
1
2 Name:       libslp-location
3 Summary:    Location Based Service
4 Version:    0.3.34
5 Release:    2
6 Group:      System/Libraries
7 License:    Apache-2.0
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post):  /sbin/ldconfig
10 Requires(post):  /usr/bin/vconftool
11 Requires(postun):  /sbin/ldconfig
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(gconf-2.0)
14 BuildRequires:  pkgconfig(dbus-glib-1)
15 BuildRequires:  pkgconfig(gmodule-2.0)
16 BuildRequires:  pkgconfig(dlog)
17 BuildRequires:  pkgconfig(vconf)
18 BuildRequires:  pkgconfig(json-glib-1.0)
19
20
21 %description
22 Location Based Service Libraries
23
24
25 %package devel
26 Summary:    Location Based Service (Development files)
27 Group:      System/Libraries
28 Requires:   %{name} = %{version}-%{release}
29
30 %description devel
31 Location Based Service Development Package
32
33
34 %prep
35 %setup -q -n %{name}-%{version}
36
37
38 %build
39
40 ./autogen.sh
41 ./configure --prefix=%{_prefix} --enable-dlog --enable-debug
42
43 # Call make instruction with smp support
44 make %{?jobs:-j%jobs}
45
46
47 %install
48 rm -rf %{buildroot}
49 %make_install
50
51
52 %clean
53 rm -rf %{buildroot}
54
55
56 %post
57 /sbin/ldconfig
58 vconftool set -t int db/location/last/gps/Timestamp "0" -f
59 vconftool set -t double db/location/last/gps/Latitude "0.0" -f
60 vconftool set -t double db/location/last/gps/Longitude "0.0" -f
61 vconftool set -t double db/location/last/gps/Altitude "0.0" -f
62 vconftool set -t double db/location/last/gps/HorAccuracy "0.0" -f
63 vconftool set -t double db/location/last/gps/VerAccuracy "0.0" -f
64 vconftool set -t double db/location/last/gps/Speed "0.0" -f
65 vconftool set -t double db/location/last/gps/Direction "0.0" -f
66 vconftool set -t int db/location/last/wps/Timestamp "0" -f
67 vconftool set -t double db/location/last/wps/Latitude "0.0" -f
68 vconftool set -t double db/location/last/wps/Longitude "0.0" -f
69 vconftool set -t double db/location/last/wps/Altitude "0.0" -f
70 vconftool set -t double db/location/last/wps/HorAccuracy "0.0" -f
71 vconftool set -t double db/location/last/wps/Speed "0.0" -f
72 vconftool set -t double db/location/last/wps/Direction "0.0" -f
73 vconftool set -t int db/location/last/sps/Timestamp "0" -f
74 vconftool set -t double db/location/last/sps/Latitude "0.0" -f
75 vconftool set -t double db/location/last/sps/Longitude "0.0" -f
76 vconftool set -t double db/location/last/sps/Altitude "0.0" -f
77 vconftool set -t double db/location/last/sps/HorAccuracy "0.0" -f
78 vconftool set -t double db/location/last/sps/VerAccuracy "0.0" -f
79 vconftool set -t int db/location/setting/GpsEnabled "0" -g 6514 -f
80 vconftool set -t int db/location/setting/AgpsEnabled "0" -g 6514 -f
81 vconftool set -t int db/location/setting/NetworkEnabled "0" -g 6514 -f
82 vconftool set -t int db/location/setting/SensorEnabled "0" -g 6514 -f
83
84
85 %postun -p /sbin/ldconfig
86
87
88 %files
89 %{_libdir}/lib*.so*
90
91
92 %files devel
93 %{_includedir}/location/*.h
94 %{_libdir}/pkgconfig/*.pc