tizen 2.3 release
[framework/connectivity/mobileap-agent.git] / packaging / mobileap-agent.spec
1 Name:           mobileap-agent
2 Summary:        Mobile AP daemon for setting tethering environments
3 Version:        1.0.12
4 Release:        1
5 Group:          System/Network
6 License:        Apache-2.0
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(dlog)
9 BuildRequires:  pkgconfig(dbus-glib-1)
10 BuildRequires:  pkgconfig(glib-2.0)
11 BuildRequires:  pkgconfig(gthread-2.0)
12 BuildRequires:  pkgconfig(deviced)
13 BuildRequires:  pkgconfig(vconf)
14 BuildRequires:  pkgconfig(notification)
15 BuildRequires:  pkgconfig(capi-network-connection)
16 BuildRequires:  pkgconfig(capi-network-bluetooth)
17 BuildRequires:  pkgconfig(syspopup-caller)
18 BuildRequires:  pkgconfig(bundle)
19 BuildRequires:  pkgconfig(appcore-common)
20 BuildRequires:  pkgconfig(capi-network-wifi-direct)
21 BuildRequires:  pkgconfig(capi-network-wifi)
22 BuildRequires:  pkgconfig(alarm-service)
23 BuildRequires:  pkgconfig(appsvc)
24 BuildRequires:  pkgconfig(libssl)
25 BuildRequires:  cmake
26 Requires(post): /usr/bin/vconftool
27 Requires(post): bluetooth-agent
28 Requires(post): ss-server
29 Requires:       iproute2
30 Requires:       iptables
31 Requires:       dnsmasq
32
33 %description
34 Mobile AP daemon for setting tethering environments
35
36 %prep
37 %setup -q
38
39
40 %build
41 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
42 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
43 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
44
45 %cmake -DCMAKE_BUILD_TYPE="" \
46         .
47
48 make %{?jobs:-j%jobs}
49
50
51 %install
52 %make_install
53
54 %post
55 /usr/bin/vconftool set -t string memory/private/mobileap-agent/ssid "" -u 0 -i -f -s system::vconf_network
56 /usr/bin/vconftool set -t int memory/mobile_hotspot/connected_device "0" -u 0 -i -f -s system::vconf_network
57 /usr/bin/vconftool set -t int memory/mobile_hotspot/mode "0" -u 0 -i -f -s system::vconf_network
58 /usr/bin/vconftool set -t int db/mobile_hotspot/security "1" -u 5000 -f -s system::vconf_network
59 /usr/bin/vconftool set -t int db/mobile_hotspot/hide "0" -u 5000 -f -s system::vconf_network
60
61 /bin/chmod +x /opt/etc/dump.d/module.d/tethering_dump.sh
62
63 %files
64 %manifest mobileap-agent.manifest
65 %defattr(-,root,root,-)
66 /usr/share/dbus-1/services/org.tizen.tethering.service
67 %{_bindir}/mobileap-agent
68 /opt/etc/dump.d/module.d/tethering_dump.sh
69