Update SMACK rule
[framework/connectivity/mobileap-agent.git] / packaging / mobileap-agent.spec
1 Name:       mobileap-agent
2 Summary:    Mobile AP daemon for setting tethering environments
3 Version:    0.1.93
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires: pkgconfig(dlog)
9 BuildRequires: pkgconfig(dbus-glib-1)
10 BuildRequires: pkgconfig(glib-2.0)
11 BuildRequires: pkgconfig(gthread-2.0)
12 BuildRequires: pkgconfig(pmapi)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(notification)
15 BuildRequires: pkgconfig(libssl)
16 BuildRequires: pkgconfig(secure-storage)
17 BuildRequires: pkgconfig(capi-network-connection)
18 BuildRequires: pkgconfig(capi-network-bluetooth)
19 BuildRequires: pkgconfig(appcore-common)
20 BuildRequires: cmake
21 Requires(post): /usr/bin/vconftool
22 Requires: iptables
23 Requires: dnsmasq
24 %description
25 Mobile AP daemon for setting tethering environments
26
27 %prep
28 %setup -q
29
30 %build
31 %cmake .
32 make %{?jobs:-j%jobs}
33
34 %install
35 %make_install
36
37 %post
38 /usr/bin/vconftool set -t int memory/mobile_hotspot/connected_device "0" -u 0 -i -f
39 /usr/bin/vconftool set -t int memory/mobile_hotspot/mode "0" -u 0 -i -f
40 /usr/bin/vconftool set -t int db/mobile_hotspot/security "0" -u 0 -f
41 /usr/bin/vconftool set -t int db/mobile_hotspot/hide "0" -u 0 -f
42
43 %files
44 %manifest mobileap-agent.manifest
45 /opt/etc/smack/accesses.d/mobileap-agent.rule
46 %defattr(-,root,root,-)
47 /usr/share/dbus-1/services/org.tizen.tethering.service
48 %{_bindir}/mobileap-agent
49
50 %changelog
51 * Tue Apr 09 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.86-1
52 - Fix the multiple notification issue
53 - Support i80211n
54 - Channel is changed to 6
55 - Implement status notification for bluetooth visibility
56 - Change the power manager api
57 - Implement connection timer
58 - Reference count is used
59 - Support Mobile AP
60
61 * Sat Feb 16 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.85-2
62 - Function return value is checked
63 - Private SSID is considered
64 - Build option clean-up and g_type_init is deprecated from glib 2.35
65
66 * Thu Feb 14 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.84-1
67 - User is specified in service file for Dbus auto activation
68
69 * Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.83-1
70 - Remove unrequired log
71
72 * Thu Jan 24 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.82-1
73 - Indications for Wi-Fi tethering setting change are added
74 - DNS Forward and Use of Tethering cellular profile are removed
75 - Dbus service / interface / object names are changed
76
77 * Mon Jan 14 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.81-1
78 - dhcp lease delete is handled based on IP Address
79 - DNS Forward by netfilter is implemented
80 - Vconf key for flight mode is changed
81
82 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.80-1
83 - Notification API's usage is changed
84 - Duplicated station information issue is fixed
85 - Improper notification type is used
86 - Timeout(Auto disconnection) feature is implemented
87 - Notification for timeout event is implemented
88
89 * Thu Nov 08 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.79-1
90 - Notification's API usage is changed
91
92 * Tue Nov 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.78-1
93 - Unnecessary BT API is removed
94
95 * Sat Nov 03 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.77-1
96 - Prevent issues are fixed
97
98 * Tue Oct 30 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.76-1
99 - Vconf enum is changed (SETTING_USB_MOBILE_HOTSPOT -> SETTING_USB_TETHERING_MODE)
100 - Private code is separated
101
102 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.75-1
103 - Code clean-up and path for notification icon is changed
104
105 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.74-1
106 - License is added
107
108 * Thu Oct 11 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.73-1
109 - Source package name is changed (libmobileap -> mobileap-agent)
110
111 * Thu Oct 11 2012 Injun Yang <injun.yang@samsung.com> 0.1.72-1
112 - Launch kcp-agent
113
114 * Fri Sep 28 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.71-1
115 - Fix memory corruption
116
117 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.70-1
118 - Manifest file is added for SMACK
119
120 * Wed Sep 19 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.69-1
121 - The code for Legacy APIs is removed
122
123 * Wed Sep 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.68-1
124 - Bluetooth PAN Managed APIs are applied
125 - MDM Phase 2 implementation
126
127 * Wed Sep 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.67-1
128 - Connection Managed APIs are applied
129 - Network status is not checked in agent
130
131 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.66-1
132 - Wi-Fi tethering setting values are managed here
133 - Deprecated APIs from glib-2.3.0 are replaced
134 - Notification Icon is changed
135
136 * Fri Jul 13 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.65-1
137 - Wi-Fi tethering disable / enable issues are fixed
138
139 * Fri Jul 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.64-1
140 - Unnecessary dependency is removed
141
142 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.63-1
143 - Data usage is fixed
144
145 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.62-1
146 - Wi-Fi tethering security is implemented
147 - API for getting USB interface information is implemented
148
149 * Wed May 23 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.61-1
150 - Tethering app. dependency is added
151
152 * Tue May 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.60-1
153 - Wi-Fi interface name is changed from eth0 to wlan0
154
155 * Tue May 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.59-1
156 - Below changes are applied
157 - Ignore mdm failure case
158 - CAPI bugs are fixed
159 - Bug of _remove_station_info_all() is fixed
160 - Launch tethering applicatoin from notification
161
162 * Tue May 08 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.58-1
163 - Hostapd control interface is implemented
164
165 * Mon Apr 09 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.57-1
166 - Unused vconfkey is removed
167
168 * Wed Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.56-1
169 - Export API's are changed
170
171 * Mon Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.55-2
172 - Fix build error
173
174 * Mon Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.55-1
175 - Test code is modified
176 - Code clean-up
177 - Notification is implemented
178 - MDM bug fix