Update Packaging Spec file
[framework/connectivity/mobileap-agent.git] / packaging / mobileap-agent.spec
1 Name:       mobileap-agent
2 Summary:    Mobile AP daemon for setting tethering environments
3 Version:    0.1.94
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires: pkgconfig(dlog)
9 BuildRequires: pkgconfig(dbus-glib-1)
10 BuildRequires: pkgconfig(glib-2.0)
11 BuildRequires: pkgconfig(gthread-2.0)
12 BuildRequires: pkgconfig(pmapi)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(notification)
15 BuildRequires: pkgconfig(libssl)
16 BuildRequires: pkgconfig(secure-storage)
17 BuildRequires: pkgconfig(capi-network-connection)
18 BuildRequires: pkgconfig(capi-network-bluetooth)
19 BuildRequires: pkgconfig(appcore-common)
20 BuildRequires: cmake
21 Requires(post): /usr/bin/vconftool
22 Requires: iptables
23 Requires: dnsmasq
24 %description
25 Mobile AP daemon for setting tethering environments
26
27 %prep
28 %setup -q
29
30 %build
31 %cmake .
32 make %{?jobs:-j%jobs}
33
34 %install
35 %make_install
36 mkdir -p %{buildroot}/usr/share/license
37 cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/%{name}
38
39
40 %post
41 /usr/bin/vconftool set -t int memory/mobile_hotspot/connected_device "0" -u 0 -i -f
42 /usr/bin/vconftool set -t int memory/mobile_hotspot/mode "0" -u 0 -i -f
43 /usr/bin/vconftool set -t int db/mobile_hotspot/security "0" -u 0 -f
44 /usr/bin/vconftool set -t int db/mobile_hotspot/hide "0" -u 0 -f
45
46 %files
47 %manifest mobileap-agent.manifest
48 /opt/etc/smack/accesses.d/mobileap-agent.rule
49 %defattr(-,root,root,-)
50 /usr/share/dbus-1/services/org.tizen.tethering.service
51 %{_bindir}/mobileap-agent
52 /usr/share/license/%{name}
53
54 %changelog
55 * Tue Apr 09 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.86-1
56 - Fix the multiple notification issue
57 - Support i80211n
58 - Channel is changed to 6
59 - Implement status notification for bluetooth visibility
60 - Change the power manager api
61 - Implement connection timer
62 - Reference count is used
63 - Support Mobile AP
64
65 * Sat Feb 16 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.85-2
66 - Function return value is checked
67 - Private SSID is considered
68 - Build option clean-up and g_type_init is deprecated from glib 2.35
69
70 * Thu Feb 14 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.84-1
71 - User is specified in service file for Dbus auto activation
72
73 * Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.83-1
74 - Remove unrequired log
75
76 * Thu Jan 24 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.82-1
77 - Indications for Wi-Fi tethering setting change are added
78 - DNS Forward and Use of Tethering cellular profile are removed
79 - Dbus service / interface / object names are changed
80
81 * Mon Jan 14 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.81-1
82 - dhcp lease delete is handled based on IP Address
83 - DNS Forward by netfilter is implemented
84 - Vconf key for flight mode is changed
85
86 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.80-1
87 - Notification API's usage is changed
88 - Duplicated station information issue is fixed
89 - Improper notification type is used
90 - Timeout(Auto disconnection) feature is implemented
91 - Notification for timeout event is implemented
92
93 * Thu Nov 08 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.79-1
94 - Notification's API usage is changed
95
96 * Tue Nov 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.78-1
97 - Unnecessary BT API is removed
98
99 * Sat Nov 03 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.77-1
100 - Prevent issues are fixed
101
102 * Tue Oct 30 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.76-1
103 - Vconf enum is changed (SETTING_USB_MOBILE_HOTSPOT -> SETTING_USB_TETHERING_MODE)
104 - Private code is separated
105
106 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.75-1
107 - Code clean-up and path for notification icon is changed
108
109 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.74-1
110 - License is added
111
112 * Thu Oct 11 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.73-1
113 - Source package name is changed (libmobileap -> mobileap-agent)
114
115 * Thu Oct 11 2012 Injun Yang <injun.yang@samsung.com> 0.1.72-1
116 - Launch kcp-agent
117
118 * Fri Sep 28 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.71-1
119 - Fix memory corruption
120
121 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.70-1
122 - Manifest file is added for SMACK
123
124 * Wed Sep 19 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.69-1
125 - The code for Legacy APIs is removed
126
127 * Wed Sep 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.68-1
128 - Bluetooth PAN Managed APIs are applied
129 - MDM Phase 2 implementation
130
131 * Wed Sep 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.67-1
132 - Connection Managed APIs are applied
133 - Network status is not checked in agent
134
135 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.66-1
136 - Wi-Fi tethering setting values are managed here
137 - Deprecated APIs from glib-2.3.0 are replaced
138 - Notification Icon is changed
139
140 * Fri Jul 13 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.65-1
141 - Wi-Fi tethering disable / enable issues are fixed
142
143 * Fri Jul 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.64-1
144 - Unnecessary dependency is removed
145
146 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.63-1
147 - Data usage is fixed
148
149 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.62-1
150 - Wi-Fi tethering security is implemented
151 - API for getting USB interface information is implemented
152
153 * Wed May 23 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.61-1
154 - Tethering app. dependency is added
155
156 * Tue May 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.60-1
157 - Wi-Fi interface name is changed from eth0 to wlan0
158
159 * Tue May 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.59-1
160 - Below changes are applied
161 - Ignore mdm failure case
162 - CAPI bugs are fixed
163 - Bug of _remove_station_info_all() is fixed
164 - Launch tethering applicatoin from notification
165
166 * Tue May 08 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.58-1
167 - Hostapd control interface is implemented
168
169 * Mon Apr 09 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.57-1
170 - Unused vconfkey is removed
171
172 * Wed Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.56-1
173 - Export API's are changed
174
175 * Mon Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.55-2
176 - Fix build error
177
178 * Mon Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.55-1
179 - Test code is modified
180 - Code clean-up
181 - Notification is implemented
182 - MDM bug fix