tizen 2.4 release
[framework/connectivity/mobileap-agent.git] / packaging / mobileap-agent.spec
1 Name:           mobileap-agent
2 Summary:        Mobile AP daemon for setting tethering environments
3 Version:        1.0.36
4 Release:        1
5 Group:          System/Network
6 License:        Apache-2.0
7 Source0:        %{name}-%{version}.tar.gz
8
9 %if "%{?tizen_profile_name}" == "tv"
10 ExcludeArch: %{arm} %ix86 x86_64
11 %endif
12
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(gio-2.0)
15 BuildRequires:  pkgconfig(glib-2.0)
16 BuildRequires:  pkgconfig(gthread-2.0)
17 BuildRequires:  pkgconfig(deviced)
18 BuildRequires:  pkgconfig(vconf)
19 BuildRequires:  pkgconfig(notification)
20 BuildRequires:  pkgconfig(capi-network-connection)
21 BuildRequires:  pkgconfig(capi-network-bluetooth)
22 BuildRequires:  pkgconfig(syspopup-caller)
23 BuildRequires:  pkgconfig(bundle)
24 BuildRequires:  pkgconfig(appcore-common)
25 BuildRequires:  pkgconfig(capi-network-wifi-direct)
26 BuildRequires:  pkgconfig(capi-network-wifi)
27 BuildRequires:  pkgconfig(alarm-service)
28 BuildRequires:  pkgconfig(appsvc)
29 BuildRequires:  pkgconfig(libssl)
30 BuildRequires:  cmake
31 Requires(post): /usr/bin/vconftool
32 %if "%{?tizen_profile_name}" != "tv"
33 Requires(post): bluetooth-agent
34 %endif
35 Requires(post): ss-server
36 Requires:       iproute2
37 Requires:       iptables
38 Requires:       dnsmasq
39
40 %description
41 Mobile AP daemon for setting tethering environments
42
43 %prep
44 %setup -q
45
46
47 %build
48 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
49 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
50 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
51
52 %cmake -DCMAKE_BUILD_TYPE="" \
53 %if "%{?tizen_profile_name}" == "tv"
54         -DTIZEN_TV=1 \
55 %endif
56 %if "%{?tizen_target_name}" == "Z300H"
57         -DTIZEN_WLAN_BOARD_SPRD=1 \
58 %endif
59         .
60
61 make %{?jobs:-j%jobs}
62
63
64 %install
65 %make_install
66
67 %post
68 /usr/bin/vconftool set -t string memory/private/mobileap-agent/ssid "" -u 0 -i -s system::vconf_network
69
70 /bin/chmod +x /opt/etc/dump.d/module.d/tethering_dump.sh
71
72 %files
73 %manifest mobileap-agent.manifest
74 %defattr(-,root,root,-)
75 /usr/share/dbus-1/system-services/org.tizen.tethering.service
76
77 %{_bindir}/mobileap-agent
78 /opt/etc/dump.d/module.d/tethering_dump.sh
79