Fix the termination issue
[framework/connectivity/data-router.git] / packaging / data-router.spec
1 Name:       data-router
2 Summary:    Data Router
3 Version:    0.2.14
4 Release:    0
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires: cmake
9 BuildRequires: pkgconfig(dlog)
10 BuildRequires: pkgconfig(dbus-glib-1)
11 BuildRequires: pkgconfig(vconf)
12 BuildRequires: pkgconfig(tapi)
13 Requires(post): /usr/bin/vconftool
14
15 %description
16 Working as a Router for USB communication
17 For USB serial communication, reads/writes usb node and routes them to Socket client application.
18
19 %prep
20 %setup -q
21
22 %build
23 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
24 make %{?jobs:-j%jobs}
25
26 %install
27 rm -rf %{buildroot}
28 %make_install
29
30
31 %post
32 /usr/bin/vconftool set -t int memory/data_router/osp_serial_open "0" -u 0 -i -f
33 %postun
34
35
36 %files
37 %defattr(-, root, root)
38 /usr/bin/data-router