cb78679402718c51c5e6ef11734ea68efcc7df38
[framework/connectivity/bluez.git] / packaging / bluez.spec
1 Name:       bluez
2 Summary:    Bluetooth utilities
3 Version:    4.101
4 Release:    2
5 Group:      Applications/System
6 License:    GPLv2+
7 URL:        http://www.bluez.org/
8 Source0:    http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.gz
9 Patch1 :    bluez-ncurses.patch
10 Requires:   dbus >= 0.60
11 Requires:   pciutils
12 BuildRequires:  pkgconfig(dbus-1)
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  flex
15 BuildRequires:  bison
16 BuildRequires:  readline-devel
17
18 %description
19 Utilities for use in Bluetooth applications:
20         --dfutool
21         --hcitool
22         --l2ping
23         --rfcomm
24         --sdptool
25         --hciattach
26         --hciconfig
27         --hid2hci
28
29 The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
30
31
32
33 %package -n libbluetooth3
34 Summary:    Libraries for use in Bluetooth applications
35 Group:      System/Libraries
36 Requires:   %{name} = %{version}-%{release}
37 Requires(post): /sbin/ldconfig
38 Requires(postun): /sbin/ldconfig
39
40 %description -n libbluetooth3
41 Libraries for use in Bluetooth applications.
42
43 %package -n libbluetooth-devel
44 Summary:    Development libraries for Bluetooth applications
45 Group:      Development/Libraries
46 Requires:   %{name} = %{version}-%{release}
47 Requires:   libbluetooth3 = %{version}
48
49 %description -n libbluetooth-devel
50 bluez-libs-devel contains development libraries and headers for
51 use in Bluetooth applications.
52
53 %prep
54 %setup -q
55 %patch1 -p1
56
57
58 %build
59
60 export CFLAGS="${CFLAGS} -D__TIZEN_PATCH__ -D__BROADCOM_PATCH__ "
61 export LDFLAGS=" -lncurses -Wl,--as-needed "
62 %reconfigure --disable-static \
63                         --sysconfdir=%{_prefix}/etc \
64                         --localstatedir=/opt/var \
65                         --enable-pie \
66                         --enable-network \
67                         --enable-serial \
68                         --enable-input \
69                         --enable-usb=no \
70                         --enable-tools \
71                         --disable-bccmd \
72                         --enable-pcmcia=no \
73                         --enable-hid2hci=no \
74                         --enable-alsa=no \
75                         --enable-gstreamer=no \
76                         --disable-dfutool \
77                         --disable-cups \
78                         --enable-health \
79                         --enable-dbusoob \
80                         --with-telephony=tizen
81
82 make %{?jobs:-j%jobs}
83
84 %install
85 rm -rf %{buildroot}
86 %make_install
87
88 install -D -m 0644 audio/audio.conf %{buildroot}%{_prefix}/etc/bluetooth/audio.conf
89 install -D -m 0644 network/network.conf %{buildroot}%{_prefix}/etc/bluetooth/network.conf
90
91
92 %post -n libbluetooth3 -p /sbin/ldconfig
93
94 %postun -n libbluetooth3 -p /sbin/ldconfig
95
96
97 %files
98 %defattr(-,root,root,-)
99 %{_prefix}/etc/bluetooth/audio.conf
100 %{_prefix}/etc/bluetooth/main.conf
101 %{_prefix}/etc/bluetooth/network.conf
102 %{_prefix}/etc/bluetooth/rfcomm.conf
103 %{_prefix}/etc/dbus-1/system.d/bluetooth.conf
104 %{_datadir}/man/*/*
105 %{_sbindir}/bluetoothd
106 %{_sbindir}/hciconfig
107 %{_sbindir}/hciattach
108 %{_bindir}/l2ping
109 %{_bindir}/sdptool
110 %{_bindir}/gatttool
111 %{_bindir}/rfcomm
112 %{_bindir}/hcitool
113 %dir %{_libdir}/bluetooth/plugins
114 %dir /opt/var/lib/bluetooth
115 %{_datadir}/dbus-1/system-services/org.bluez.service
116
117
118 %files -n libbluetooth3
119 %defattr(-,root,root,-)
120 %{_libdir}/libbluetooth.so.*
121
122
123 %files -n libbluetooth-devel
124 %defattr(-, root, root)
125 %{_includedir}/bluetooth/*
126 %{_libdir}/libbluetooth.so
127 %{_libdir}/pkgconfig/bluez.pc