tizen 2.0 beta
[framework/appfw/ui-gadget-1.git] / packaging / ui-gadget-1.spec
1
2 Name:       ui-gadget-1
3 Summary:    UI Gadget Library
4 Version:    0.1.0
5 Release:    8
6 Group:      TO_BE/FILLED_IN
7 License:    TO BE FILLED IN
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  pkgconfig(utilX)
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(appcore-efl)
14 BuildRequires:  pkgconfig(bundle)
15 BuildRequires:  pkgconfig(dlog)
16 BuildRequires:  pkgconfig(x11)
17 BuildRequires:  pkgconfig(appsvc)
18 BuildRequires:  pkgconfig(capi-appfw-application)
19 BuildRequires:  cmake
20 BuildRequires:  edje-bin
21
22 %description
23 UI gadget library (development headers)
24
25 %package devel
26 Summary:    Development files for %{name}
27 Group:      Development/Libraries
28 Requires:   %{name} = %{version}-%{release}
29 %description devel
30 Development files for %{name}
31
32 %prep
33 %setup -q
34
35 %build
36 cmake . -DCMAKE_INSTALL_PREFIX=/usr
37
38 make %{?jobs:-j%jobs}
39
40 %install
41 rm -rf %{buildroot}
42 %make_install
43
44 %post 
45 /sbin/ldconfig
46 ln -sf /usr/bin/ug-client /usr/bin/ug-launcher
47
48 %postun -p /sbin/ldconfig
49
50 %files
51 %defattr(-,root,root,-)
52 %{_libdir}/*.so.*
53 %{_libdir}/lib%{name}-efl-engine.so
54 /usr/share/edje/ug_effect.edj
55 %{_bindir}/ug-client
56 /usr/share/edje/ug-client/*.edj
57
58 %files devel
59 %defattr(-,root,root,-)
60 %{_includedir}/ug-1/*.h
61 %{_libdir}/*.so
62 %{_libdir}/pkgconfig/%{name}.pc
63