move to appcore_get_rotation_state in the last of app_create
[framework/appfw/ui-gadget-1.git] / packaging / ui-gadget-1.spec
1
2 Name:       ui-gadget-1
3 Summary:    UI Gadget Library
4 Version:    0.1.0
5 Release:    11
6 Group:      TO_BE/FILLED_IN
7 License:    TO BE FILLED IN
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  pkgconfig(utilX)
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(appcore-efl)
14 BuildRequires:  pkgconfig(bundle)
15 BuildRequires:  pkgconfig(dlog)
16 BuildRequires:  pkgconfig(x11)
17 BuildRequires:  pkgconfig(appsvc)
18 BuildRequires:  pkgconfig(capi-appfw-application)
19 BuildRequires:  pkgconfig(capi-system-runtime-info)
20 BuildRequires:  cmake
21 BuildRequires:  edje-bin
22
23 %description
24 UI gadget library (development headers)
25
26 %package devel
27 Summary:    Development files for %{name}
28 Group:      Development/Libraries
29 Requires:   %{name} = %{version}-%{release}
30 %description devel
31 Development files for %{name}
32
33 %prep
34 %setup -q
35
36 %build
37 cmake . -DCMAKE_INSTALL_PREFIX=/usr
38
39 make %{?jobs:-j%jobs}
40
41 %install
42 rm -rf %{buildroot}
43 %make_install
44
45 %post 
46 /sbin/ldconfig
47 ln -sf /usr/bin/ug-client /usr/bin/ug-launcher
48
49 %postun -p /sbin/ldconfig
50
51 %files
52 %defattr(-,root,root,-)
53 %{_libdir}/*.so.*
54 %{_libdir}/lib%{name}-efl-engine.so
55 /usr/share/edje/ug_effect.edj
56 %{_bindir}/ug-client
57 /usr/share/edje/ug-client/*.edj
58
59 %files devel
60 %defattr(-,root,root,-)
61 %{_includedir}/ug-1/*.h
62 %{_libdir}/libui-gadget-1.so
63 %{_libdir}/pkgconfig/%{name}.pc
64