enable to read valgrind outputfile without root on
[framework/appfw/debug-launchpad.git] / packaging / debug-launchpad.spec
1 Name:       debug-launchpad
2 Summary:    Debug Launchpad
3 Version:    0.0.5
4 Release:    1
5 Group:      System Environment/Daemons
6 License:    Apache License, Version 2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
9
10 Requires(post): /sbin/ldconfig
11 Requires(post): /usr/bin/systemctl
12 Requires(postun): /sbin/ldconfig
13 Requires(postun): /usr/bin/systemctl
14 Requires(preun): /usr/bin/systemctl
15
16 BuildRequires:  cmake
17 BuildRequires:  pkgconfig(dbus-glib-1)
18 BuildRequires:  pkgconfig(sqlite3)
19 BuildRequires:  pkgconfig(x11)
20 BuildRequires:  pkgconfig(bundle)
21 BuildRequires:  pkgconfig(dlog)
22 BuildRequires:  pkgconfig(libprivilege-control)
23 BuildRequires:  pkgconfig(vconf)
24 BuildRequires:  pkgconfig(libsmack)
25 BuildRequires:  pkgconfig(aul)
26
27
28 %description
29 Debug launchpad
30
31 %prep
32 %setup -q
33
34 %build
35 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
36 make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40 %make_install
41
42 %clean
43 rm -rf %{buildroot}
44
45 %post
46
47 %files
48 %attr(0755, root, root) %{_bindir}/debug_launchpad_preloading_preinitializing_daemon