5e90ea0afe38fd29e2fc2fe89dee0bab942c4f5d
[framework/appfw/debug-launchpad.git] / packaging / debug-launchpad.spec
1 Name:       debug-launchpad
2 Summary:    Debug Launchpad
3 Version:    0.0.2
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache License, Version 2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 Requires(post): /sbin/ldconfig
10 Requires(post): /usr/bin/systemctl
11 Requires(postun): /sbin/ldconfig
12 Requires(postun): /usr/bin/systemctl
13 Requires(preun): /usr/bin/systemctl
14
15 BuildRequires:  cmake
16 BuildRequires:  pkgconfig(dbus-glib-1)
17 BuildRequires:  pkgconfig(sqlite3)
18 BuildRequires:  pkgconfig(x11)
19 BuildRequires:  pkgconfig(bundle)
20 BuildRequires:  pkgconfig(dlog)
21 BuildRequires:  pkgconfig(libprivilege-control)
22 BuildRequires:  pkgconfig(vconf)
23 BuildRequires:  pkgconfig(libsmack)
24 BuildRequires:  pkgconfig(aul)
25
26
27 %description
28 Debug launchpad
29
30 %prep
31 %setup -q
32
33 %build
34 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
35 make %{?jobs:-j%jobs}
36
37 %install
38 rm -rf %{buildroot}
39 %make_install
40
41 %post
42
43 %files
44 %{_bindir}/debug_launchpad_preloading_preinitializing_daemon