tizen 2.3 release
[framework/appfw/aul-1.git] / packaging / aul.spec
1 Name:       aul
2 Summary:    App utility library
3 Version:    0.2.3.0
4 Release:    6
5 Group:      System/Libraries
6 License:    Apache License, Version 2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source101:  ac.service
9 Source102:  launchpad-preload.service
10
11 Requires(post): /sbin/ldconfig
12 Requires(post): /usr/bin/systemctl
13 Requires(postun): /sbin/ldconfig
14 Requires(postun): /usr/bin/systemctl
15 Requires(preun): /usr/bin/systemctl
16
17 BuildRequires:  cmake
18 BuildRequires:  pkgconfig(dbus-glib-1)
19 BuildRequires:  pkgconfig(sqlite3)
20 BuildRequires:  pkgconfig(x11)
21 BuildRequires:  pkgconfig(ecore)
22 BuildRequires:  pkgconfig(bundle)
23 BuildRequires:  pkgconfig(dlog)
24 BuildRequires:  pkgconfig(ail)
25 BuildRequires:  xdgmime-devel, pkgconfig(xdgmime)
26 BuildRequires:  pkgconfig(libprivilege-control)
27 BuildRequires:  pkgconfig(app-checker)
28 BuildRequires:  pkgconfig(app-checker-server)
29 BuildRequires:  pkgconfig(rua)
30 BuildRequires:  pkgconfig(ecore-x)
31 BuildRequires:  pkgconfig(ecore-input)
32 BuildRequires:  pkgconfig(utilX)
33 BuildRequires:  pkgconfig(vconf)
34 BuildRequires:  pkgconfig(pkgmgr-info)
35 BuildRequires:  pkgconfig(libsmack)
36 #BuildRequires:  pkgconfig(system-resource)
37 BuildRequires:  pkgconfig(libresourced)
38 BuildRequires:  pkgconfig(security-server)
39
40 %define feature_appfw_integrated_contact_phone 1
41 %define feature_appfw_multi_instance 1
42 %define feature_appfw_process_pool 1
43 %define keepstatic 1
44 %if "%{?tizen_profile_name}" == "wearable"
45 %define appfw_feature_process_pool_common 1
46 %define appfw_feature_hw_rendering 0
47 %elseif "%{?tizen_profile_name}" == "mobile"
48 %define appfw_feature_process_pool_common 0
49 %define appfw_feature_hw_rendering 1
50 %endif
51 %define appfw_feature_priority_change 1
52 %define appfw_feature_default_fake_image 0
53 %define appfw_feature_data_control 1
54 %define appfw_feature_debug_launchpad 1
55 %define appfw_feature_app_control_lite 0
56 %define appfw_feature_native_launchpad 0
57 %if "%{?tizen_profile_name}" == "wearable"
58 %define appfw_feature_bg_process_limit 0
59 %define appfw_feature_app_checker 0
60 %define appfw_feature_tts_mode 1
61 %elseif "%{?tizen_profile_name}" == "mobile"
62 %define appfw_feature_bg_process_limit 1
63 %define appfw_feature_app_checker 1
64 %define appfw_feature_tts_mode 0
65 %endif
66 %define appfw_feature_ultra_power_saving_mode 0
67 %if "%{?tizen_profile_name}" == "wearable"
68 %define appfw_feature_visibility_check_by_lcd_status 1
69 %elseif "%{?tizen_profile_name}" == "mobile"
70 %define appfw_feature_visibility_check_by_lcd_status 0
71 %endif
72
73 %description
74 Application utility library
75
76 %package devel
77 Summary:    App utility library (devel)
78 Group:      Development/Libraries
79 Requires:   %{name} = %{version}-%{release}
80
81 %description devel
82 Application utility library (devel)
83
84
85 %prep
86 %setup -q
87
88 %build
89 %if 0%{?sec_build_binary_debug_enable}
90 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
91 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
92 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
93 %endif
94 %if 0%{?feature_appfw_process_pool}
95 _APPFW_FEATURE_PROCESS_POOL=ON
96  %if 0%{?appfw_feature_process_pool_common}
97  _APPFW_FEATURE_PROCESS_POOL_COMMON=ON
98  %else
99   %if 0%{?appfw_feature_hw_rendering}
100   _APPFW_FEATURE_PROCESS_POOL_HW_RENDERING=ON
101   %endif
102  %endif
103 %endif
104 %if 0%{?feature_appfw_multi_instance}
105 _APPFW_FEATURE_MULTI_INSTANCE=ON
106 %endif
107 %if 0%{?feature_appfw_integrated_contact_phone}
108 _APPFW_FEATURE_CONTACT_PHONE_AS_ONE_APP=ON
109 %endif
110 %if 0%{?appfw_feature_priority_change}
111 _APPFW_FEATURE_PRIORITY_CHANGE=ON
112 %endif
113 %if 0%{?appfw_feature_default_fake_image}
114 _APPFW_FEATURE_DEFAULT_FAKE_IMAGE=ON
115 %endif
116 %if 0%{?appfw_feature_data_control}
117 _APPFW_FEATURE_DATA_CONTROL=ON
118 %endif
119 %if 0%{?appfw_feature_debug_launchpad}
120 _APPFW_FEATURE_DEBUG_LAUNCHPAD=ON
121 %endif
122 %if 0%{?appfw_feature_app_control_lite}
123 _APPFW_FEATURE_APP_CONTROL_LITE=ON
124 %endif
125 %if 0%{?appfw_feature_native_launchpad}
126 _APPFW_FEATURE_NATIVE_LAUNCHPAD=ON
127 %endif
128 %if 0%{?appfw_feature_bg_process_limit}
129 _APPFW_FEATURE_BG_PROCESS_LIMIT=ON
130 %endif
131 %if 0%{?appfw_feature_app_checker}
132 _APPFW_FEATURE_APP_CHECKER=ON
133 %endif
134 %if 0%{?appfw_feature_tts_mode}
135 _APPFW_FEATURE_TTS_MODE=ON
136 %endif
137 %if 0%{?appfw_feature_ultra_power_saving_mode}
138 _APPFW_FEATURE_ULTRA_POWER_SAVING_MODE=ON
139 %endif
140 %if 0%{?appfw_feature_visibility_check_by_lcd_status}
141 _APPFW_FEATURE_VISIBILITY_CHECK_BY_LCD_STATUS=ON
142 %endif
143
144 cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} \
145         -D_APPFW_FEATURE_PROCESS_POOL:BOOL=${_APPFW_FEATURE_PROCESS_POOL} \
146         -D_APPFW_FEATURE_PROCESS_POOL_COMMON:BOOL=${_APPFW_FEATURE_PROCESS_POOL_COMMON} \
147         -D_APPFW_FEATURE_PROCESS_POOL_HW_RENDERING:BOOL=${_APPFW_FEATURE_PROCESS_POOL_HW_RENDERING} \
148         -D_APPFW_FEATURE_MULTI_INSTANCE:BOOL=${_APPFW_FEATURE_MULTI_INSTANCE} \
149         -D_APPFW_FEATURE_MULTI_WINDOW:BOOL=${_APPFW_FEATURE_MULTI_WINDOW} \
150         -D_APPFW_FEATURE_CHANGEABLE_COLOR:BOOL=${_APPFW_FEATURE_CHANGEABLE_COLOR} \
151         -D_APPFW_FEATURE_CPU_BOOST:BOOL=${_APPFW_FEATURE_CPU_BOOST} \
152         -D_APPFW_FEATURE_CONTACT_PHONE_AS_ONE_APP:BOOL=${_APPFW_FEATURE_CONTACT_PHONE_AS_ONE_APP} \
153         -D_APPFW_FEATURE_PRIORITY_CHANGE:BOOL=${_APPFW_FEATURE_PRIORITY_CHANGE} \
154         -D_APPFW_FEATURE_DEFAULT_FAKE_IMAGE:BOOL=${_APPFW_FEATURE_DEFAULT_FAKE_IMAGE} \
155         -D_APPFW_FEATURE_DATA_CONTROL:BOOL=${_APPFW_FEATURE_DATA_CONTROL} \
156         -D_APPFW_FEATURE_DEBUG_LAUNCHPAD:BOOL=${_APPFW_FEATURE_DEBUG_LAUNCHPAD} \
157         -D_APPFW_FEATURE_APP_CONTROL_LITE:BOOL=${_APPFW_FEATURE_APP_CONTROL_LITE} \
158         -D_APPFW_FEATURE_NATIVE_LAUNCHPAD:BOOL=${_APPFW_FEATURE_NATIVE_LAUNCHPAD} \
159         -D_APPFW_FEATURE_WMS_CONNECTION_CHECK:BOOL=${_APPFW_FEATURE_WMS_CONNECTION_CHECK} \
160         -D_APPFW_FEATURE_BG_PROCESS_LIMIT:BOOL=${_APPFW_FEATURE_BG_PROCESS_LIMIT} \
161         -D_APPFW_FEATURE_APP_CHECKER:BOOL=${_APPFW_FEATURE_APP_CHECKER} \
162         -D_APPFW_FEATURE_TTS_MODE:BOOL=${_APPFW_FEATURE_TTS_MODE} \
163         -D_APPFW_FEATURE_ULTRA_POWER_SAVING_MODE:BOOL=${_APPFW_FEATURE_ULTRA_POWER_SAVING_MODE} \
164         -D_APPFW_FEATURE_VISIBILITY_CHECK_BY_LCD_STATUS:BOOL=${_APPFW_FEATURE_VISIBILITY_CHECK_BY_LCD_STATUS} \
165         .
166
167 make %{?jobs:-j%jobs}
168
169 %install
170 rm -rf %{buildroot}
171 %make_install
172
173 mkdir -p %{buildroot}/opt/dbspace
174 %if 0%{?appfw_feature_default_fake_image}
175 mkdir -p %{buildroot}/usr/share/splash_images
176 cp -raf effect_img/* %{buildroot}/usr/share/splash_images
177 %endif
178 mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants
179 install -m0644 %SOURCE101 %{buildroot}%{_libdir}/systemd/system/ac.service
180 ln -s ../ac.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/ac.service
181 install -m0644 %SOURCE102 %{buildroot}%{_libdir}/systemd/system/launchpad-preload.service
182 ln -s ../launchpad-preload.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/launchpad-preload.service
183 mkdir -p %{buildroot}/usr/share/license
184 cp LICENSE %{buildroot}/usr/share/license/%{name}
185
186
187 %post
188 vconftool set -t int db/setting/effect_image 1 -f -s system::vconf_inhouse
189
190
191 %files
192 %manifest aul.manifest
193 %attr(0644,root,root) %{_libdir}/libaul.so.0
194 %attr(0644,root,root) %{_libdir}/libaul.so.0.1.0
195 %if 0%{?appfw_feature_default_fake_image}
196 %attr(0755,root,root) %{_bindir}/config_splash.sh
197 %endif
198 %{_bindir}/aul_test
199 %{_bindir}/launch_app
200 %{_bindir}/open_app
201 /usr/share/aul/miregex/*
202 /usr/share/aul/preload_list.txt
203 /usr/share/aul/preexec_list.txt
204 %if 0%{?appfw_feature_default_fake_image}
205 /usr/share/splash_images/*
206 %endif
207 %{_bindir}/launchpad_preloading_preinitializing_daemon
208 %{_bindir}/amd
209 %{_bindir}/daemon-manager-release-agent
210 %{_bindir}/daemon-manager-launch-agent
211 %{_libdir}/systemd/system/ac.service
212 %{_libdir}/systemd/system/multi-user.target.wants/ac.service
213 %{_libdir}/systemd/system/launchpad-preload.service
214 %{_libdir}/systemd/system/multi-user.target.wants/launchpad-preload.service
215 /usr/share/license/%{name}
216
217 %files devel
218 %{_includedir}/aul/*.h
219 %{_includedir}/aul/launch/*.h
220 %{_includedir}/aul/launchpad/*.h
221 %{_libdir}/*.so
222 %{_libdir}/*.a
223 %{_libdir}/pkgconfig/*.pc