Upload Tizen2.0 source
[framework/appfw/app-core.git] / packaging / app-core.spec
1
2 Name:       app-core
3 Summary:    Application basic
4 Version:    1.2
5 Release:    25
6 Group:      TO_BE/FILLED_IN
7 License:    Apache License, Version 2.0
8 Source0:    app-core-%{version}.tar.gz
9 BuildRequires:  pkgconfig(sensor)
10 BuildRequires:  pkgconfig(vconf)
11 BuildRequires:  pkgconfig(aul)
12 BuildRequires:  pkgconfig(rua)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(x11)
15 BuildRequires:  pkgconfig(sysman)
16 BuildRequires:  pkgconfig(elementary)
17 BuildRequires:  pkgconfig(ecore)
18 BuildRequires:  pkgconfig(ecore-x)
19 BuildRequires:  pkgconfig(gobject-2.0)
20 BuildRequires:  pkgconfig(glib-2.0)
21 BuildRequires:  cmake
22 BuildRequires:  sysman-devel
23
24
25 %description
26 SLP common application basic
27
28
29
30 %package efl
31 Summary:    App basic EFL
32 Group:      Development/Libraries
33 Requires(post): /sbin/ldconfig
34 Requires(postun): /sbin/ldconfig
35
36 %description efl
37 Application basic EFL
38
39 %package efl-devel
40 Summary:    App basic EFL (devel)
41 Group:      Development/Libraries
42 Requires:   %{name}-efl = %{version}-%{release}
43 Requires:   %{name}-common-devel = %{version}-%{release}
44
45 %description efl-devel
46 Application basic EFL (devel)
47
48 %package common
49 Summary:    App basics common
50 Group:      Development/Libraries
51 Requires(post): /sbin/ldconfig
52 Requires(postun): /sbin/ldconfig
53
54 %description common
55 Application basics common
56
57 %package common-devel
58 Summary:    App basics common (devel)
59 Group:      Development/Libraries
60 Requires:   %{name}-common = %{version}-%{release}
61 Requires:   pkgconfig(sensor)
62 Requires:   pkgconfig(vconf)
63 Requires:   pkgconfig(elementary)
64 Requires:   pkgconfig(aul)
65
66 %description common-devel
67 Application basics common (devel)
68
69 %package template
70 Summary:    App basics template
71 Group:      Development/Libraries
72
73 %description template
74 Application basics template
75
76
77 %prep
78 %setup -q 
79
80 %build
81 CFLAGS="-I/usr/lib/glib-2.0/include/ -I/usr/include/glib-2.0 -I/usr/lib/dbus-1.0/include -I/usr/include/dbus-1.0 -I/usr/include/e_dbus-1 -I/usr/include/ethumb-0 -I/usr/include/edje-1 -I/usr/include/efreet-1 -I/usr/include/embryo-1 -I/usr/include/ecore-1 -I/usr/include/eet-1 -I/usr/include/evas-1 -I/usr/include/eina-1 -I/usr/include/eina-1/eina  $(CFLAGS)" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DENABLE_GTK=OFF
82
83
84 make %{?jobs:-j%jobs}
85
86 %install
87 rm -rf %{buildroot}
88 %make_install
89
90
91 %post efl -p /sbin/ldconfig
92
93 %postun efl -p /sbin/ldconfig
94
95 %post common -p /sbin/ldconfig
96
97 %postun common -p /sbin/ldconfig
98
99
100
101
102
103 %files efl
104 %defattr(-,root,root,-)
105 %{_libdir}/libappcore-efl.so.*
106
107 %files efl-devel
108 %defattr(-,root,root,-)
109 %{_includedir}/appcore/appcore-efl.h
110 %{_libdir}/libappcore-efl.so
111 %{_libdir}/pkgconfig/appcore-efl.pc
112
113 %files common
114 %defattr(-,root,root,-)
115 %{_libdir}/libappcore-common.so.*
116
117 %files common-devel
118 %defattr(-,root,root,-)
119 %{_libdir}/libappcore-common.so
120 %{_libdir}/pkgconfig/appcore-common.pc
121 %{_includedir}/appcore/appcore-common.h
122 %{_includedir}/SLP_Appcore_PG.h
123