8b338ee89369d1c311b844cd66630aeca604d2bd
[framework/appfw/app-core.git] / packaging / app-core.spec
1 Name:       app-core
2 Summary:    Application basic
3 Version:    1.2
4 Release:    19
5 Group:      TO_BE/FILLED_IN
6 License:    Apache License, Version 2.0
7 Source0:    app-core-%{version}.tar.gz
8 BuildRequires:  pkgconfig(sensor)
9 BuildRequires:  pkgconfig(vconf)
10 BuildRequires:  pkgconfig(aul)
11 BuildRequires:  pkgconfig(rua)
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(x11)
14 BuildRequires:  pkgconfig(sysman)
15 BuildRequires:  pkgconfig(elementary)
16 BuildRequires:  pkgconfig(ecore)
17 BuildRequires:  pkgconfig(ecore-x)
18 BuildRequires:  pkgconfig(gobject-2.0)
19 BuildRequires:  pkgconfig(glib-2.0)
20 BuildRequires:  cmake
21 BuildRequires:  sysman-devel
22
23
24 %description
25 SLP common application basic
26
27
28
29 %package efl
30 Summary:    App basic EFL
31 Group:      Development/Libraries
32 Requires(post): /sbin/ldconfig
33 Requires(postun): /sbin/ldconfig
34
35 %description efl
36 Application basic EFL
37
38 %package efl-devel
39 Summary:    App basic EFL (devel)
40 Group:      Development/Libraries
41 Requires:   %{name}-efl = %{version}-%{release}
42 Requires:   %{name}-common-devel = %{version}-%{release}
43
44 %description efl-devel
45 Application basic EFL (devel)
46
47 %package common
48 Summary:    App basics common
49 Group:      Development/Libraries
50 Requires(post): /sbin/ldconfig
51 Requires(postun): /sbin/ldconfig
52
53 %description common
54 Application basics common
55
56 %package common-devel
57 Summary:    App basics common (devel)
58 Group:      Development/Libraries
59 Requires:   %{name}-common = %{version}-%{release}
60 Requires:   pkgconfig(sensor)
61 Requires:   pkgconfig(vconf)
62 Requires:   pkgconfig(elementary)
63 Requires:   pkgconfig(aul)
64
65 %description common-devel
66 Application basics common (devel)
67
68 %package template
69 Summary:    App basics template
70 Group:      Development/Libraries
71
72 %description template
73 Application basics template
74
75
76 %prep
77 %setup -q 
78
79 %build
80 CFLAGS="-I/usr/lib/glib-2.0/include/ -I/usr/include/glib-2.0 -I/usr/lib/dbus-1.0/include -I/usr/include/dbus-1.0 -I/usr/include/e_dbus-1 -I/usr/include/ethumb-0 -I/usr/include/edje-1 -I/usr/include/efreet-1 -I/usr/include/embryo-1 -I/usr/include/ecore-1 -I/usr/include/eet-1 -I/usr/include/evas-1 -I/usr/include/eina-1 -I/usr/include/eina-1/eina  $(CFLAGS)" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DENABLE_GTK=OFF
81
82
83 make %{?jobs:-j%jobs}
84
85 %install
86 rm -rf %{buildroot}
87 %make_install
88
89
90 %post efl -p /sbin/ldconfig
91
92 %postun efl -p /sbin/ldconfig
93
94 %post common -p /sbin/ldconfig
95
96 %postun common -p /sbin/ldconfig
97
98
99
100
101
102 %files efl
103 %{_libdir}/libappcore-efl.so.*
104
105 %files efl-devel
106 %{_includedir}/appcore/appcore-efl.h
107 %{_libdir}/libappcore-efl.so
108 %{_libdir}/pkgconfig/appcore-efl.pc
109
110 %files common
111 %{_libdir}/libappcore-common.so.*
112
113 %files common-devel
114 %{_libdir}/libappcore-common.so
115 %{_libdir}/pkgconfig/appcore-common.pc
116 %{_includedir}/appcore/appcore-common.h
117 %{_includedir}/SLP_Appcore_PG.h
118
119