change Group
[framework/api/url-download.git] / packaging / capi-web-url-download.spec
1
2 Name:   capi-web-url-download
3 Summary:        CAPI for content download with web url
4 Version:        0.0.8
5 Release:        9
6 Group:          Development/Libraries
7 License:        TO_BE_FILLED_IN
8 URL:            N/A
9 Source0:        %{name}-%{version}.tar.gz
10 BuildRequires: pkgconfig(capi-base-common)
11 BuildRequires: pkgconfig(bundle)
12 BuildRequires: pkgconfig(dlog)
13 BuildRequires: pkgconfig(capi-appfw-app-manager)
14 BuildRequires: pkgconfig(capi-appfw-application)
15 BuildRequires: pkgconfig(download-provider)
16 BuildRequires: cmake
17 BuildRequires: expat-devel
18
19 %description
20 CAPI for the content download
21
22 %package devel
23 Summary:        url download
24 Group:          Development/Libraries
25 Requires:       %{name} = %{version}-%{release}
26
27 %description devel
28 CAPI for content downloading with web url (developement files)
29
30 %prep
31 %setup -q
32
33 %build
34 cmake . -DCMAKE_INSTALL_PREFIX="/"
35
36 make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40 %make_install
41
42 %post -p /sbin/ldconfig
43
44 %postun -p /sbin/ldconfig
45
46 %files
47 %defattr(-,root,root,-)
48 %{_libdir}/libcapi-web-url-download.so
49
50 %files devel
51 %defattr(-,root,root,-)
52 %{_libdir}/libcapi-web-url-download.so
53 %{_libdir}/pkgconfig/capi-web-url-download.pc
54 /usr/include/web/url_download.h
55
56 %changelog
57 * Fri Sep 07 2012 Kwangmin Bang <justine.bang@samsung.com>
58 - fix timeout thread can run exactly
59
60 * Thu Sep 06 2012 Kwangmin Bang <justine.bang@samsung.com>
61 - check the state before clear socket
62 - add limitation in already completed state
63 - add checking INVALID_STATE error
64
65 * Tue Sep 04 2012 Jungki Kwak <jungki.kwak@samsung.com>
66 - Remove unused code which is base on libdownload-agent
67 - Change the name of application operation
68 - Add exception handling for non requestid
69 - Call clear_provider after getting the state
70 - url_download_get_state return IO error
71 - Resolve prevent defects
72
73 * Mon Sep 03 2012 Kwangmin Bang <justine.bang@samsung.com>
74 - stop the download even if no socket or callback
75 - pause/resume the download even if no socket or callback
76 - calling stopped callback in error case
77 - request STOP for free after finished download
78
79 * Thu Aug 30 2012 Kwangmin Bang <justine.bang@samsung.com>
80 - maxfd should be updated before created event thread
81
82 * Thu Aug 30 2012 Kwangmin Bang <justine.bang@samsung.com>
83 - remove duplicated call for creating socket
84 - fix the crash regarding pthread_kill
85 - allow to call url_download_stop in case of PAUSED state
86
87 * Mon Aug 27 2012 Kwangmin Bang <justine.bang@samsung.com>
88 - one thread model for event
89 - get state info from download-provider even if no connection
90 - fix the bug take a long time to receive first event
91
92 * Tue Aug 22 2012 Jungki Kwak <jungki.kwak@samsung.com>
93 - Enhance the exception handling in event thread
94 - Resolve a bug about state
95 - Add to pass service handle data to download daemon
96
97 * Mon Aug 17 2012 Jungki Kwak <jungki.kwak@samsung.com>
98 - Resolve a bug when getting a state
99 - Add error case for invalid id
100
101 * Mon Aug 16 2012 Jungki Kwak <jungki.kwak@samsung.com>
102 - Add new APIs for notification function
103 - The TC is changed due to change of url_download_start
104 - When unseting the callback function, the callback should be initialized although the error is happened.
105 - It remove the stop function when is called twice when destroying handle
106 - Add pc requries for app.h
107
108 * Mon Aug 08 2012 Jungki Kwak <jungki.kwak@samsung.com>
109 - Change requestid to INTEGER from String
110
111 * Mon Aug 06 2012 Jungki Kwak <jungki.kwak@samsung.com>
112 - The base model is changed to download provider daemon
113