upload tizen1.0 source
[framework/api/sim.git] / packaging / capi-telephony-sim.spec
index 58039ea..536f1d6 100644 (file)
@@ -1,9 +1,9 @@
 Name:       capi-telephony-sim
 Summary:    Telephony SIM Framework
-Version:    0.0.1
-Release:    1
+Version:    0.1.0
+Release:    12
 Group:      TO_BE/FILLED_IN
-License:    TO BE FILLED IN
+License:    Apache-2.0
 Source0:    %{name}-%{version}.tar.gz
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(dlog)
@@ -31,7 +31,8 @@ Requires: %{name} = %{version}-%{release}
 
 
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=/usr
+MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
+cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
 
 
 make %{?jobs:-j%jobs}
@@ -46,10 +47,11 @@ rm -rf %{buildroot}
 
 
 %files
-%{_libdir}/libcapi-telephony-sim.so
+%{_libdir}/libcapi-telephony-sim.so.*
 
 %files devel
 %{_includedir}/telephony/sim.h
 %{_libdir}/pkgconfig/*.pc
+%{_libdir}/libcapi-telephony-sim.so