286c28190afdf06422c1535c0a10ba03d9b0248c
[framework/api/power.git] / packaging / capi-system-power.spec
1 #sbs-git:slp/api/power capi-system-power 0.1.0 0432661af455f52366bdcd809dc72a00854c763c
2 Name:       capi-system-power
3 Summary:    A power library in Tizen C API
4 Version: 0.1.0
5 Release:    7
6 Group:      TO_BE/FILLED_IN
7 License:    TO BE FILLED IN
8 Source0:    %{name}-%{version}.tar.gz
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(pmapi)
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(capi-base-common)
14 BuildRequires:  pkgconfig(vconf)
15
16 Requires(post): /sbin/ldconfig  
17 Requires(postun): /sbin/ldconfig
18
19 %description
20
21
22 %package devel
23 Summary:  A power library in Tizen C API (Development)
24 Group:    TO_BE/FILLED_IN
25 Requires: %{name} = %{version}-%{release}
26
27 %description devel
28
29
30
31 %prep
32 %setup -q
33
34
35 %build
36 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
37 cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
38
39
40 make %{?jobs:-j%jobs}
41
42 %install
43 rm -rf %{buildroot}
44 %make_install
45
46 %post -p /sbin/ldconfig
47
48 %postun -p /sbin/ldconfig
49
50
51 %files
52 %{_libdir}/libcapi-system-power.so.*
53
54 %files devel
55 %{_includedir}/system/power.h
56 %{_libdir}/pkgconfig/*.pc
57 %{_libdir}/libcapi-system-power.so
58
59