tizen 2.3 release
[framework/api/location-manager.git] / packaging / capi-location-manager.spec
1 #sbs-git:slp/api/location-manager capi-location-manager 0.1.0 d1ee09a32e8bc0e9ed48ece37c641a7393c086c5
2 Name:           capi-location-manager
3 Summary:        A Location Manager library in Tizen Native API
4 Version:        0.4.0
5 Release:        1
6 Group:          System/Libraries
7 License:        Apache License, Version 2.0
8 Source0:        %{name}-%{version}.tar.gz
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(location)
12 BuildRequires:  pkgconfig(capi-base-common)
13 BuildRequires:  pkgconfig(vconf)
14 Requires(post): /sbin/ldconfig
15 Requires(postun): /sbin/ldconfig
16
17 %description
18
19
20 %package devel
21 Summary: A Location Manager library in Tizen Native API (Development)
22 Group:  TO_BE/FILLED_IN
23 Requires: %{name} = %{version}-%{release}
24
25 %description devel
26
27
28
29 %prep
30 %setup -q
31
32
33 %build
34 #%if "%{_repository}" == "wearable“
35 #export CFLAGS="$CFLAGS -DTIZEN_WEARABLE"
36 #%endif
37
38 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
39 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
40 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
41
42 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
43 cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
44
45 make %{?jobs:-j%jobs}
46
47 %install
48 rm -rf %{buildroot}
49 %make_install
50
51 mkdir -p %{buildroot}/usr/share/license
52 cp LICENSE %{buildroot}/usr/share/license/%{name}
53
54 %post -p /sbin/ldconfig
55
56 %postun -p /sbin/ldconfig
57
58
59 %files
60 %manifest capi-location-manager.manifest
61 %{_libdir}/libcapi-location-manager.so.*
62 /usr/share/license/%{name}
63
64 %files devel
65 %{_includedir}/location/*.h
66 %{_libdir}/pkgconfig/*.pc
67 %{_libdir}/libcapi-location-manager.so
68
69