upload source
[external/xmlsec1.git] / xmlsec1.spec
1 Summary: Library providing support for "XML Signature" and "XML Encryption" standards
2 Name: xmlsec1
3 Version: 1.2.14
4 Release: 1
5 License: MIT
6 Group: Development/Libraries
7 Vendor: Aleksey Sanin <aleksey@aleksey.com>
8 Distribution:  Aleksey Sanin <aleksey@aleksey.com>
9 Packager: Aleksey Sanin <aleksey@aleksey.com>
10 Source: ftp://ftp.aleksey.com/pub/xmlsec/releases/xmlsec1-%{version}.tar.gz
11 BuildRoot: %{_tmppath}/xmlsec1-%{version}-root
12 URL: http://www.aleksey.com/xmlsec
13 Requires: libxml2 >= 2.7.4
14 Requires: libxslt >= 1.0.20
15 Requires: ltdl
16 BuildRequires: libxml2-devel >= 2.7.4
17 BuildRequires: libxslt-devel >= 1.0.20
18 Prefix: %{_prefix}
19 Docdir: %{_docdir}
20
21 %define _unpackaged_files_terminate_build  0 
22 %define _missing_doc_files_terminate_build 0
23
24 %description
25 XML Security Library is a C library based on LibXML2  and OpenSSL. 
26 The library was created with a goal to support major XML security 
27 standards "XML Digital Signature" and "XML Encryption". 
28
29 %package devel 
30 Summary: Libraries, includes, etc. to develop applications with XML Digital Signatures and XML Encryption support.
31 Group: Development/Libraries 
32 Requires: xmlsec1 = %{version}
33 Requires: libxml2-devel >= 2.7.4
34 Requires: libxslt-devel >= 1.0.20
35 Requires: openssl-devel >= 0.9.6
36 Requires: zlib-devel 
37
38 %description devel
39 Libraries, includes, etc. you can use to develop applications with XML Digital 
40 Signatures and XML Encryption support.
41
42 %package openssl
43 Summary: OpenSSL crypto plugin for XML Security Library
44 Group: Development/Libraries 
45 Requires: xmlsec1 = %{version}
46 Requires: libxml2 >= 2.7.4
47 Requires: libxslt >= 1.0.20
48 Requires: openssl >= 0.9.6
49 BuildRequires: openssl-devel >= 0.9.6
50
51 %description openssl
52 OpenSSL plugin for XML Security Library provides OpenSSL based crypto services
53 for the xmlsec library
54
55 %package openssl-devel
56 Summary: OpenSSL crypto plugin for XML Security Library
57 Group: Development/Libraries 
58 Requires: xmlsec1 = %{version}
59 Requires: xmlsec1-devel = %{version}
60 Requires: xmlsec1-openssl = %{version}
61 Requires: libxml2-devel >= 2.7.4
62 Requires: libxslt-devel >= 1.0.20
63 Requires: openssl >= 0.9.6
64 Requires: openssl-devel >= 0.9.6
65
66 %description openssl-devel
67 Libraries, includes, etc. for developing XML Security applications with OpenSSL
68
69 %package nss
70 Summary: NSS crypto plugin for XML Security Library
71 Group: Development/Libraries 
72 Requires: xmlsec1 = %{version}
73 Requires: libxml2 >= 2.7.4
74 Requires: libxslt >= 1.0.20
75 Requires: mozilla-nss >= 1.4
76 BuildRequires: mozilla-nss-devel >= 1.4
77
78 %description nss
79 NSS plugin for XML Security Library provides NSS based crypto services
80 for the xmlsec library
81
82 %package nss-devel
83 Summary: NSS crypto plugin for XML Security Library
84 Group: Development/Libraries 
85 Requires: xmlsec1 = %{version}
86 Requires: xmlsec1-devel = %{version}
87 Requires: xmlsec1-nss = %{version}
88 Requires: libxml2-devel >= 2.7.4
89 Requires: libxslt-devel >= 1.0.20
90 Requires: mozilla-nss-devel >= 1.4
91
92 %description nss-devel
93 Libraries, includes, etc. for developing XML Security applications with NSS
94
95 %prep
96 %setup -q
97
98 %build
99 # Needed for snapshot releases.
100 if [ ! -f configure ]; then
101 %ifarch alpha
102   CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --host=alpha-redhat-linux --prefix=%prefix --sysconfdir="/etc" --mandir=%{_mandir}
103 %else
104   CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%prefix --sysconfdir="/etc" --mandir=%{_mandir}
105 %endif
106 else
107 %ifarch alpha
108   CFLAGS="$RPM_OPT_FLAGS" ./configure --host=alpha-redhat-linux --prefix=%prefix --sysconfdir="/etc" --mandir=%{_mandir}
109 %else
110   CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%prefix --sysconfdir="/etc" --mandir=%{_mandir}
111 %endif
112 fi
113 if [ "$SMP" != "" ]; then
114   (make "MAKE=make -k -j $SMP"; exit 0)
115   make
116 else
117   make
118 fi
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 mkdir -p $RPM_BUILD_ROOT/usr/bin
123 mkdir -p $RPM_BUILD_ROOT/usr/include/xmlsec1
124 mkdir -p $RPM_BUILD_ROOT/usr/lib
125 mkdir -p $RPM_BUILD_ROOT/usr/man/man1
126 make prefix=$RPM_BUILD_ROOT%{prefix} mandir=$RPM_BUILD_ROOT%{_mandir} install
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post -p /sbin/ldconfig
132
133 %postun -p /sbin/ldconfig
134
135 %files 
136 %defattr(-, root, root)
137
138 %doc AUTHORS ChangeLog NEWS README Copyright
139 %doc %{_mandir}/man1/xmlsec1.1*
140
141 %{prefix}/lib/libxmlsec1.so.*
142 %{prefix}/lib/libxmlsec1.so
143 %{prefix}/bin/xmlsec1
144
145 %files devel
146 %defattr(-, root, root)  
147
148 %{prefix}/bin/xmlsec1-config
149 %{prefix}/include/xmlsec1/xmlsec/*.h
150 %{prefix}/include/xmlsec1/xmlsec/private/*.h
151 %{prefix}/lib/libxmlsec1.*a
152 %{prefix}/lib/pkgconfig/xmlsec1.pc
153 %{prefix}/lib/xmlsec1Conf.sh
154 %{prefix}/share/doc/xmlsec1/* 
155 %{prefix}/share/aclocal/xmlsec1.m4
156 %doc AUTHORS HACKING ChangeLog NEWS README Copyright
157 %doc %{_mandir}/man1/xmlsec1-config.1*
158
159 %files openssl
160 %defattr(-, root, root)  
161
162 %{prefix}/lib/libxmlsec1-openssl.so.*
163 %{prefix}/lib/libxmlsec1-openssl.so
164
165 %files openssl-devel
166 %defattr(-, root, root)  
167
168 %{prefix}/include/xmlsec1/xmlsec/openssl/*.h
169 %{prefix}/lib/libxmlsec1-openssl.*a
170 %{prefix}/lib/pkgconfig/xmlsec1-openssl.pc
171
172 %files nss
173 %defattr(-, root, root)  
174
175 %{prefix}/lib/libxmlsec1-nss.so.*
176 %{prefix}/lib/libxmlsec1-nss.so
177
178 %files nss-devel
179 %defattr(-, root, root)  
180
181 %{prefix}/include/xmlsec1/xmlsec/nss/*.h
182 %{prefix}/lib/libxmlsec1-nss.*a
183 %{prefix}/lib/pkgconfig/xmlsec1-nss.pc
184
185 %changelog