c8d5def04c225e55616e809dea07b8b1af08268b
[external/xmlsec1.git] / packaging / xmlsec1.spec
1
2 Name:       xmlsec1
3 Summary:    Library providing support for "XML Signature" and "XML Encryption" standards
4 Version:    1.2.14
5 Release:    1
6 Group:      System/Libraries
7 License:    MIT
8 URL:        http://www.aleksey.com/xmlsec/index.html
9 Source0:    http://www.aleksey.com/xmlsec/download/xmlsec1-%{version}.tar.gz
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12 BuildRequires:  pkgconfig(libxml-2.0) >= 2.6.27
13 BuildRequires:  pkgconfig(libxslt)
14 BuildRequires:  pkgconfig(openssl)
15
16
17 %description
18 This C library allows to transform XML files into other XML files
19 (or HTML, text, ...) using the standard XSLT stylesheet transformation
20 mechanism. To use it you need to have a version of libxml2 >= 2.6.27
21 installed. The xsltproc command is a command line interface to the XSLT engine
22
23
24
25 %package openssl
26 Summary:    OpenSSL crypto plugin for XML Security Library
27 Group:      System/Libraries
28 Requires:   %{name} = %{version}-%{release}
29 Requires(post): /sbin/ldconfig
30 Requires(postun): /sbin/ldconfig
31
32 %description openssl
33 OpenSSL plugin for XML Security Library provides OpenSSL based crypto services
34 for the xmlsec library.
35
36
37 %package devel
38 Summary:    Libraries, includes, etc. to develop applications with XML Digital Signatures and XML Encryption support.
39 Group:      Development/Libraries
40 Requires:   %{name} = %{version}-%{release}
41
42 %description devel
43 This C library allows to transform XML files into other XML files
44 (or HTML, text, ...) using the standard XSLT stylesheet transformation
45 mechanism. To use it you need to have a version of libxml2 >= 2.6.27
46 installed.
47
48
49
50 %prep
51 %setup -q -n %{name}-%{version}
52
53
54 %build
55
56 %configure --disable-static \
57     --enable-dynamic --disable-crypto-dl --disable-apps-crypto-dl --without-gnutls
58
59 make %{?jobs:-j%jobs}
60
61 %install
62 rm -rf %{buildroot}
63 %make_install
64
65
66
67
68 %post -p /sbin/ldconfig
69
70 %postun -p /sbin/ldconfig
71
72
73
74 %post openssl -p /sbin/ldconfig
75
76 %postun openssl -p /sbin/ldconfig
77
78
79
80
81 %files
82 %defattr(-,root,root,-)
83 %doc Copyright AUTHORS README NEWS ChangeLog
84 %{_libdir}/libxmlsec1.so.*
85 /usr/bin/xmlsec1
86 /usr/share/man/man1/xmlsec1.1.gz
87
88
89 %files openssl
90 %defattr(-,root,root,-)
91 %{_libdir}/libxmlsec1-openssl.so.*
92
93 %files devel
94 %defattr(-,root,root,-)
95 %doc Copyright ChangeLog AUTHORS README NEWS TODO
96 /usr/include/*
97 /usr/bin/xmlsec1-config
98 %{_libdir}/lib*.so
99 %{_libdir}/pkgconfig/*
100 %{_libdir}/xmlsec1Conf.sh
101 /usr/share/doc/xmlsec1/*
102 /usr/share/man/man1/xmlsec1-config.1.gz
103 /usr/share/aclocal/xmlsec1.m4
104