Initail import package wget: A utility for retrieving files using the HTTP or FTP...
[external/wget.git] / packaging / wget.spec
1 Name:       wget
2 Summary:    A utility for retrieving files using the HTTP or FTP protocols
3 Version:    1.12
4 Release:    1
5 Group:      Applications/Internet
6 License:    GPLv3+
7 URL:        http://wget.sunsite.dk/
8 Source0:    ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.bz2
9 Patch0:     wget-1.12-path.patch
10 Patch1:     wget-1.10.1-helpfix.patch
11 Patch2:     wget-1.12-CVE-2010-2252.patch
12 BuildRequires:  pkgconfig(openssl)
13 BuildRequires:  pkgconfig
14 BuildRequires:  texinfo
15 BuildRequires:  gettext
16 BuildRequires:  autoconf
17 Provides:   webclient
18
19
20 %description
21 GNU Wget is a file retrieval utility which can use either the HTTP or
22 FTP protocols. Wget features include the ability to work in the
23 background while you are logged out, recursive retrieval of
24 directories, file name wildcard matching, remote file timestamp
25 storage and comparison, use of Rest with FTP servers and Range with
26 HTTP servers to retrieve files over slow or unstable connections,
27 support for Proxy servers, and configurability.
28
29
30
31
32 %prep
33 %setup -q -n %{name}-%{version}
34
35 # wget-1.12-path.patch
36 %patch0 -p1
37 # wget-1.10.1-helpfix.patch
38 %patch1 -p1
39 # wget-1.12-CVE-2010-2252.patch
40 %patch2 -p1
41
42 %build
43 if pkg-config openssl ; then
44 CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
45 LDFLAGS=`pkg-config --libs openssl`; export LDFLAGS
46 fi
47
48 %configure --disable-static \
49     --with-ssl \
50     --enable-largefile \
51     --enable-opie \
52     --enable-digest \
53     --enable-ntlm \
54     --enable-nls \
55     --enable-ipv6 \
56     --disable-rpath
57
58 make %{?jobs:-j%jobs}
59
60 %install
61 %make_install
62
63 rm -rf %{buildroot}/%{_infodir}
64 %find_lang wget
65
66 %lang_package
67
68 %files 
69 %doc doc/sample.wgetrc
70 %doc %{_mandir}/man1/wget.*
71 %config(noreplace) %{_sysconfdir}/wgetrc
72 %{_bindir}/wget
73
74