smack merge from tizen_2.1_smack
[external/ragel.git] / packaging / ragel.spec
1 Name:       ragel
2 Summary:    Ragel
3 Version:    6.6
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    %{name}-%{version}.tar.gz
8 Patch0:     no-doc.patch
9
10 %description
11 compiles finite state machines into code in various languages
12 Ragel compiles finite state machines from regular languages into C, C++,
13 Objective-C, D, Ruby or Java code. Ragel allows the programmer to embed
14 actions at any point in a regular language. Non-determinism can be
15 controlled through the use of embedded priorities and guarded regular
16 language operators. Ragel also supports the construction of scanners and
17 the building of state machines using state-charts. Ragel can be used to
18 create robust recognizers and parsers which run very fast. It can work
19 with integer-sized alphabets and can compile large state machines.
20 The generated code has no dependencies.
21
22
23 %prep
24 %setup -q 
25 %patch0 -p1
26
27
28 %build
29 ./autogen.sh
30 ./configure --prefix=%{_prefix}
31
32 make %{?jobs:-j%jobs}
33
34
35 %install
36 rm -rf %{buildroot}
37 %make_install
38 mkdir -p %{buildroot}/usr/share/license
39 cp %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/usr/share/license/%{name}
40
41 %remove_docs
42
43 %files
44 %manifest ragel.manifest
45 %{_bindir}/ragel
46 /usr/share/license/%{name}