tizen 2.3.1 release
[external/ragel.git] / packaging / ragel.spec
1 Name:       ragel
2 Summary:    Ragel
3 Version:    6.8
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    %{name}-%{version}.tar.gz
8 Patch0:     no-doc.patch
9
10
11 %description
12 compiles finite state machines into code in various languages
13 Ragel compiles finite state machines from regular languages into C, C++,
14 Objective-C, D, Ruby or Java code. Ragel allows the programmer to embed
15 actions at any point in a regular language. Non-determinism can be
16 controlled through the use of embedded priorities and guarded regular
17 language operators. Ragel also supports the construction of scanners and
18 the building of state machines using state-charts. Ragel can be used to
19 create robust recognizers and parsers which run very fast. It can work
20 with integer-sized alphabets and can compile large state machines.
21 The generated code has no dependencies.
22
23
24 %prep
25 %setup -q 
26 %patch0 -p1
27
28
29 %build
30 ./autogen.sh
31 ./configure --prefix=%{_prefix}
32
33 make %{?jobs:-j%jobs}
34
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39 mkdir -p %{buildroot}/usr/share/license
40 cp %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/usr/share/license/%{name}
41
42
43 %files
44 %{_bindir}/ragel
45 %{_defaultdocdir}/*
46 /usr/share/license/%{name}