Git init
[external/popt.git] / popt.spec
1 #
2 # Note: popt is now an rpm sub-package (including libpopt.so*) so you probably
3 # shouldn't need to use this spec file to package popt anymore.
4 #
5 Summary: A C library for parsing command line parameters.
6 Name: popt
7 Version: 1.7
8 Release: 0.1
9 Copyright: X Consortium
10 Group: System Environment/Libraries
11 Source: ftp://ftp.redhat.com/pub/redhat/code/popt/popt-%{version}.tar.gz
12 BuildRoot: /var/tmp/%{name}root
13
14 %description
15 Popt is a C library for parsing command line parameters.  Popt
16 was heavily influenced by the getopt() and getopt_long() functions,
17 but it improves on them by allowing more powerful argument expansion.
18 Popt can parse arbitrary argv[] style arrays and automatically set
19 variables based on command line arguments.  Popt allows command
20 line arguments to be aliased via configuration files and includes
21 utility functions for parsing arbitrary strings into argv[] arrays
22 using shell-like rules.
23
24 Install popt if you're a C programmer and you'd like to use its
25 capabilities.
26
27 %prep
28 %setup -q
29
30 %build
31 #CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr
32
33 %configure
34 make
35
36 %install
37 make DESTDIR=$RPM_BUILD_ROOT install
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(-,root,root)
44 %{_prefix}/lib/libpopt.*
45 %{_prefix}/include/popt.h
46 %{_prefix}/man/man3/popt.3
47 %{_prefix}/share/locale/*/LC_MESSAGES/popt.mo
48
49 %changelog
50 * Thu Dec 10 1998 Michael Johnson <johnsonm@redhat.com>
51 - released 1.2.2; see CHANGES
52
53 * Tue Nov 17 1998 Michael K. Johnson <johnsonm@redhat.com>
54 - added man page to default install
55
56 * Thu Oct 22 1998 Erik Troan <ewt@redhat.com>
57 - see CHANGES file for 1.2
58
59 * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
60 - added ./configure step to spec file