90e45ee0123a7e47eb5afdd536a956f4766472da
[external/pango1.0.git] / packaging / pango.spec
1 %define freetype_version 2.1.3-3
2 %define fontconfig_version 2.6
3 %define cairo_version 1.7.6
4
5 Name:       pango
6 Summary:    System for layout and rendering of internationalized text
7 Version:    1.26.1
8 Release:    3.2
9 Group:      System/GUI/GNOME
10 License:    LGPLv2+
11 URL:        http://www.pango.org
12 Source0:    http://download.gnome.org/sources/pango/1.26/pango-%{version}.tar.gz
13 Patch0: 10_scan-module-files-in-dirs.patch
14 Patch1: 11_module-files-append-module-files-d.patch
15 Patch2: 12_module-files-append-compat-module-files-d.patch
16 BuildRequires:  pkgconfig(glib-2.0)
17 BuildRequires:  pkgconfig(freetype2) >= %{freetype_version}
18 BuildRequires:  pkgconfig(fontconfig) >= %{fontconfig_version}
19 BuildRequires:  pkgconfig(xt)
20 BuildRequires:  pkgconfig(xrender)
21 BuildRequires:  pkgconfig(x11)
22 BuildRequires:  pkgconfig(xext)
23 BuildRequires:  pkgconfig(xft)
24 BuildRequires:  pkgconfig(cairo) >= %{cairo_version}
25
26 %description
27 Pango is a library for laying out and rendering of text, with an emphasis
28 on internationalization. Pango can be used anywhere that text layout is needed,
29 though most of the work on Pango so far has been done in the context of the
30 GTK+ widget toolkit. Pango forms the core of text and font handling for GTK+.
31
32 Pango is designed to be modular; the core Pango layout engine can be used
33 with different font backends.
34
35 The integration of Pango with Cairo provides a complete solution with high
36 quality text handling and graphics rendering.
37
38 %package    devel
39 Summary:    Development files for pango
40 Group:      Development/Libraries
41 Requires:   %{name} = %{version}-%{release}
42
43 %description devel
44 The pango-devel package includes the header files and developer documentation
45 for the pango package.
46
47 %define MODVER 1.6.0
48
49 %prep
50 %setup -q
51 %patch0 -p1
52 %patch1 -p1
53 %patch2 -p1
54
55 %build
56
57 %configure --disable-static \
58         --sysconfdir=/etc \
59         --with-x \
60         --enable-freetype \
61         --disable-glibtest \
62         --enable-explicit-deps=yes \
63         --enable-gtk-doc=no \
64         ac_cv_lib_cairo_cairo_xlib_surface_create=yes \
65         ac_cv_lib_cairo_cairo_ft_scaled_font_lock_face=yes
66
67 make %{?jobs:-j%jobs}
68
69 %install
70 rm -rf %{buildroot}
71 %make_install
72 rm -rf $RPM_BUILD_ROOT/usr/share/gtk-doc
73 rm -rf $RPM_BUILD_ROOT/usr/share/man
74
75 mkdir -p %{buildroot}%{_libdir}/pango/%{MODVER}/module-files.d
76 touch $RPM_BUILD_ROOT%{_libdir}/pango/%{MODVER}/module-files.d/%{name}.modules
77
78 %post
79 /sbin/ldconfig
80 %{_bindir}/pango-querymodules > %{_libdir}/pango/%{MODVER}/module-files.d/%{name}.modules
81
82 %postun -p /sbin/ldconfig
83
84 %files
85 %{_libdir}/libpango*-*.so.*
86 %{_libdir}/pango
87 %{_bindir}/pango-querymodules
88
89 %files devel
90 %{_libdir}/libpango*.so
91 %{_includedir}/*
92 %{_libdir}/pkgconfig/*.pc
93 %{_bindir}/pango-view
94 %dir %{_sysconfdir}/pango
95 %config %{_sysconfdir}/pango/pangox.aliases