Git init
[external/pango1.0.git] / packaging / pango.spec
1 %define freetype_version 2.1.3-3
2 %define fontconfig_version 2.6
3 %define cairo_version 1.7.6
4
5 Name:       pango
6 Summary:    System for layout and rendering of internationalized text
7 Version:    1.26.1
8 Release:    1
9 Group:      System/GUI/GNOME
10 License:    LGPLv2+
11 URL:        http://www.pango.org
12 Source0:    http://download.gnome.org/sources/pango/1.26/pango-%{version}.tar.gz
13 Patch0: 10_scan-module-files-in-dirs.patch
14 Patch1: 11_module-files-append-module-files-d.patch
15 Patch2: 12_module-files-append-compat-module-files-d.patch
16 Requires(post): /sbin/ldconfig
17 Requires(postun): /sbin/ldconfig
18 Requires(post): /usr/bin/pango-querymodules
19 BuildRequires:  pkgconfig(glib-2.0)
20 BuildRequires:  pkgconfig(freetype2) >= %{freetype_version}
21 BuildRequires:  pkgconfig(fontconfig) >= %{fontconfig_version}
22 BuildRequires:  pkgconfig(xt)
23 BuildRequires:  pkgconfig(xrender)
24 BuildRequires:  pkgconfig(x11)
25 BuildRequires:  pkgconfig(xext)
26 BuildRequires:  pkgconfig(xft)
27 BuildRequires:  pkgconfig(cairo) >= %{cairo_version}
28
29 %description
30 Pango is a library for laying out and rendering of text, with an emphasis
31 on internationalization. Pango can be used anywhere that text layout is needed,
32 though most of the work on Pango so far has been done in the context of the
33 GTK+ widget toolkit. Pango forms the core of text and font handling for GTK+.
34
35 Pango is designed to be modular; the core Pango layout engine can be used
36 with different font backends.
37
38 The integration of Pango with Cairo provides a complete solution with high
39 quality text handling and graphics rendering.
40
41
42 %package -n libpango
43 Summary:    Pango Library
44 Group:      System/Libraries
45
46 %description -n libpango
47 Pango is a library for laying out and rendering of text, with an emphasis
48 on internationalization. Pango can be used anywhere that text layout is needed,
49 though most of the work on Pango so far has been done in the context of the
50 GTK+ widget toolkit. Pango forms the core of text and font handling for GTK+.
51
52 Pango is designed to be modular; the core Pango layout engine can be used
53 with different font backends.
54
55 The integration of Pango with Cairo provides a complete solution with high
56 quality text handling and graphics rendering.
57
58
59 %package -n libpango-devel
60 Summary:    Development files for pango
61 Group:      Development/Libraries
62 Requires:   lib%{name} = %{version}-%{release}
63
64 %description -n libpango-devel
65 The pango-devel package includes the header files and developer documentation
66 for the pango package.
67
68 %prep
69 %setup -q 
70 %patch0 -p1
71 %patch1 -p1
72 %patch2 -p1
73
74 %build
75
76 %configure --disable-static \
77         --sysconfdir=/etc \
78         --with-x \
79         --enable-freetype \
80         --disable-glibtest \
81         --enable-explicit-deps=yes \
82         --enable-gtk-doc=no \
83         ac_cv_lib_cairo_cairo_xlib_surface_create=yes \
84         ac_cv_lib_cairo_cairo_ft_scaled_font_lock_face=yes
85
86 make %{?jobs:-j%jobs}
87
88 %install
89 rm -rf %{buildroot}
90 %make_install
91 rm -rf $RPM_BUILD_ROOT/usr/share/gtk-doc
92 rm -rf $RPM_BUILD_ROOT/usr/share/man
93
94 touch $RPM_BUILD_ROOT%{_sysconfdir}/pango/pango.modules
95 mkdir -p %{buildroot}/etc/pango
96
97
98
99 %post -n libpango -p /sbin/ldconfig
100 %{_bindir}/pango-querymodules > %{_sysconfdir}/pango/pango.modules
101
102 %postun -n libpango -p /sbin/ldconfig
103
104 %files
105 %{_bindir}/pango-querymodules
106 %{_bindir}/pango-view
107 %dir %{_sysconfdir}/pango
108 %config %{_sysconfdir}/pango/pangox.aliases
109 %ghost %{_sysconfdir}/pango/pango.modules
110
111
112 %files -n libpango
113 %{_libdir}/libpango*-*.so.*
114 %{_libdir}/pango
115 %dir /etc/pango
116
117
118 %files -n libpango-devel
119 %{_libdir}/libpango*.so
120 %{_includedir}/*
121 %{_libdir}/pkgconfig/*.pc
122