tizen 2.0
[external/ltrace.git] / ltrace.spec
1 Summary: Tracks runtime library calls from dynamically linked executables.
2 Name: ltrace
3 Version: 0.3.36
4 Release: 4.2
5 Source: ftp://ftp.debian.org/debian/pool/main/l/ltrace/ltrace_%{version}.orig.tar.gz
6 Patch1: ftp://ftp.debian.org/debian/pool/main/l/ltrace/ltrace_0.3.36-2.diff.gz
7 Patch2: ltrace-ppc64.patch
8 Patch3: ltrace-ppc64-2.patch
9 Patch4: ltrace-s390x.patch
10 Patch5: ltrace-syscallent-update.patch
11 Patch6: ltrace-fixes.patch
12 Patch7: ltrace-ia64.patch
13 License: GPL
14 Group: Development/Debuggers
15 ExclusiveArch: i386 x86_64 ia64 ppc ppc64 s390 s390x alpha sparc
16 Prefix: %{_prefix}
17 BuildRoot: /var/tmp/%{name}-root
18 BuildRequires: elfutils-libelf-devel
19
20 %description
21 Ltrace is a debugging program which runs a specified command until the
22 command exits.  While the command is executing, ltrace intercepts and
23 records both the dynamic library calls called by the executed process
24 and the signals received by the executed process.  Ltrace can also
25 intercept and print system calls executed by the process.
26
27 You should install ltrace if you need a sysadmin tool for tracking the
28 execution of processes.
29
30 %prep
31 %setup -q
32 %patch1 -p1
33 %patch2 -p1
34 %patch3 -p1
35 %patch4 -p1
36 %patch5 -p1
37 %patch6 -p1
38 %patch7 -p1
39 sed -i -e 's/-o root -g root//' Makefile.in
40
41 %build
42 export CC="gcc`echo $RPM_OPT_FLAGS | sed -n 's/^.*\(-m[36][124]\).*$/ \1/p'`"
43 %configure CC="$CC"
44 make
45
46 %install
47 make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
48 rm -f ChangeLog; mv -f debian/changelog ChangeLog
49 rm -rf $RPM_BUILD_ROOT/%{_prefix}/doc
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(-,root,root)
56 %doc COPYING README TODO BUGS ChangeLog
57 %{_prefix}/bin/ltrace
58 %{_mandir}/man1/ltrace.1*
59 %config /etc/ltrace.conf
60
61 %changelog
62 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.36-4.2
63 - bump again for double-long bug on ppc(64)
64
65 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.36-4.1
66 - rebuilt for new gcc4.1 snapshot and glibc changes
67
68 * Mon Jan  9 2006 Jakub Jelinek <jakub@redhat.com> 0.3.36-4
69 - added ppc64 and s390x support (IBM)
70 - added ia64 support (Ian Wienand)
71
72 * Sat Mar  5 2005 Jakub Jelinek <jakub@redhat.com> 0.3.36-3
73 - rebuilt with GCC 4
74
75 * Tue Dec 14 2004 Jakub Jelinek <jakub@redhat.com> 0.3.36-2
76 - make x86_64 ltrace trace both 32-bit and 64-bit binaries (#141955,
77   IT#55600)
78 - fix tracing across execve
79 - fix printf-style format handling on 64-bit arches
80
81 * Thu Nov 18 2004 Jakub Jelinek <jakub@redhat.com> 0.3.36-1
82 - update to 0.3.36
83
84 * Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 0.3.35-1
85 - update to 0.3.35
86 - update syscall tables from latest kernel source
87
88 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
89 - rebuilt
90
91 * Tue Jun  8 2004 Jakub Jelinek <jakub@redhat.com> 0.3.32-3
92 - buildreq elfutils-libelf-devel (#124921)
93
94 * Thu Apr 22 2004 Jakub Jelinek <jakub@redhat.com> 0.3.32-2
95 - fix demangling
96
97 * Thu Apr 22 2004 Jakub Jelinek <jakub@redhat.com> 0.3.32-1
98 - update to 0.3.32
99   - fix dict.c assertion (#114359)
100   - x86_64 support
101 - rewrite elf.[ch] using libelf
102 - don't rely on st_value of SHN_UNDEF symbols in binaries,
103   instead walk .rel{,a}.plt and compute the addresses (#115299)
104 - fix x86-64 support
105 - some ltrace.conf additions
106 - some format string printing fixes
107
108 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
109 - rebuilt
110
111 * Mon Feb  3 2003 Jakub Jelinek <jakub@redhat.com> 0.3.29-1
112 - update to 0.3.29
113
114 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
115 - rebuilt
116
117 * Sun Sep  1 2002 Jakub Jelinek <jakub@redhat.com> 0.3.10-12
118 - add a bunch of missing functions to ltrace.conf
119   (like strlen, ugh)
120
121 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
122 - automated rebuild
123
124 * Tue May 28 2002 Phil Knirsch <pknirsch@redhat.com>
125 - Added the 'official' s390 patch.
126
127 * Thu May 23 2002 Tim Powers <timp@redhat.com>
128 - automated rebuild
129
130 * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
131 - automated rebuild
132
133 * Fri Jul 20 2001 Jakub Jelinek <jakub@redhat.com>
134 - fix stale symlink in documentation directory (#47749)
135
136 * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
137 - Bump release + rebuild.
138
139 * Thu Aug  2 2000 Tim Waugh <twaugh@redhat.com>
140 - fix off-by-one problem in checking syscall number
141
142 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
143 - automatic rebuild
144
145 * Mon Jun 19 2000 Matt Wilson <msw@redhat.com>
146 - rebuilt for next release
147 - patched Makefile.in to take a hint on mandir (patch2)
148 - use %%{_mandir} and %%makeinstall
149
150 * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
151 - fix description
152
153 * Fri Jan  7 2000 Jeff Johnson <jbj@redhat.com>
154 - update to 0.3.10.
155 - include (but don't apply) sparc patch from Jakub Jellinek.
156
157 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> 
158 - auto rebuild in the new build environment (release 2)
159
160 * Fri Mar 12 1999 Jeff Johnson <jbj@redhat.com>
161 - update to 0.3.6.
162
163 * Mon Sep 21 1998 Preston Brown <pbrown@redhat.com>
164 - upgraded to 0.3.4