Git init
[external/libsndfile.git] / packaging / libsndfile.spec
1
2 Name:       libsndfile
3 Summary:    Library for reading and writing sound files
4 Version:    1.0.21
5 Release:    1
6 Group:      System/Libraries
7 License:    LGPLv2+
8 URL:        http://www.mega-nerd.com/libsndfile/
9 Source0:    http://www.mega-nerd.com/libsndfile/libsndfile-%{version}.tar.gz
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12 BuildRequires:  pkgconfig(alsa)
13 #BuildRequires:  pkgconfig(ogg)
14 BuildRequires:  pkgconfig(vorbis)
15
16
17 %description
18 libsndfile is a C library for reading and writing sound files such as
19 AIFF, AU, WAV, and others through one standard interface. It can
20 currently read/write 8, 16, 24 and 32-bit PCM files as well as 32 and
21 64-bit floating point WAV files and a number of compressed formats. It
22 compiles and runs on *nix, MacOS, and Win32.
23
24
25
26 %package devel
27 Summary:    Development files for libsndfile
28 Group:      Development/Libraries
29 Requires:   %{name} = %{version}-%{release}
30
31 %description devel
32 libsndfile is a C library for reading and writing sound files such as
33 AIFF, AU, WAV, and others through one standard interface.
34 This package contains files needed to develop with libsndfile.
35
36
37
38 %prep
39 %setup -q -n %{name}-%{version}
40
41
42 %build
43
44 %configure --disable-static \
45     --disable-dependency-tracking
46
47 make %{?jobs:-j%jobs}
48
49 %install
50 rm -rf %{buildroot}
51 %make_install
52
53
54
55
56 %post -p /sbin/ldconfig
57
58 %postun -p /sbin/ldconfig
59
60
61
62 %docs_package
63
64
65 %files
66 %defattr(-,root,root,-)
67 %doc COPYING 
68 %{_bindir}/*
69 %{_libdir}/%{name}.so.*
70
71
72 %files devel
73 %defattr(-,root,root,-)
74 %{_includedir}/sndfile.h
75 %{_includedir}/sndfile.hh
76 %{_libdir}/%{name}.so
77 %{_libdir}/pkgconfig/sndfile.pc
78 /usr/share/doc/libsndfile1-dev
79