Package Upload. Added myself to Uploaders.
[external/libremix.git] / remix.spec
1
2 %define name    remix
3 %define version 0.2.4
4 %define release 1
5 %define prefix  /usr
6
7 Summary: An audio rendering library
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 Prefix: %{prefix}
12 Copyright: LGPL
13 Group: Libraries/Sound
14 Source: http://www.metadecks.org/software/remix/download/libremix-%{version}.tar.gz
15 URL: http://www.metadecks.org/software/remix/
16 BuildRoot: /var/tmp/%{name}-%{version}
17
18 %description
19 Remix is a library for rendering audio data.
20
21 %package devel
22 Summary: Libraries, includes, etc to develop remix applications
23 Group: Libraries
24
25 %description devel
26 Libraries, include files, etc you can use to develop remix applications.
27
28 %prep
29 %setup
30
31 %build
32 ./configure --prefix=%{prefix}
33 make
34
35 %install
36 if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
37 mkdir -p $RPM_BUILD_ROOT
38 make prefix=$RPM_BUILD_ROOT%{prefix} install
39
40 %clean
41 if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
42
43 %files
44 %defattr(-,root,root)
45 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO doc
46 %prefix/lib/libremix.so.*
47
48 %files devel
49 %defattr(-,root,root)
50 %{prefix}/lib/libremix.a
51 %{prefix}/lib/libremix.la
52 %{prefix}/lib/libremix.so
53 %{prefix}/include/remix.h
54 %{prefix}/include/remix_plugin.h
55
56 %changelog
57 * Tue Sep 18 2001 Conrad Parker <Conrad.Parker@CSIRO.AU>
58 - Created axel.spec.in (hacked from libsndfile.spec.in)