tizen 2.4 release
[external/libjson-glib.git] / packaging / json-glib.spec
1 %bcond_with introspection
2
3 Name:           json-glib
4 Version:        1.0.2
5 Release:        0
6 License:        LGPL-2.1+
7 Summary:        Library for JavaScript Object Notation format
8 Url:            http://live.gnome.org/JsonGlib
9 Group:          System/Libraries
10 #X-Vcs-Url:     git://git.gnome.org/json-glib
11 Source0:        http://download.gnome.org/sources/json-glib/%{version}/%{name}-%{version}.tar.xz
12 Source99:       baselibs.conf
13 Source1001:     json-glib.manifest
14 %if %{with introspection}
15 BuildRequires:  gobject-introspection-devel
16 %endif
17 BuildRequires:  pkgconfig(glib-2.0)
18
19 %description
20 JSON is a lightweight data-interchange format.It is easy for humans to
21 read and write. It is easy for machines to parse and generate.
22
23 JSON-GLib provides a parser and a generator GObject classes and various
24 wrappers for the complex data types employed by JSON, such as arrays
25 and objects.
26
27 JSON-GLib uses GLib native data types and the generic value container
28 GValue for ease of development. It also provides integration with the
29 GObject classes for direct serialization into, and deserialization from,
30 JSON data streams.
31
32 %package -n typelib-Json
33 Summary:        Library for JavaScript Object Notation format -- Introspection bindings
34 Group:          System/Libraries
35
36 %description -n typelib-Json
37 JSON is a lightweight data-interchange format.It is easy for humans to
38 read and write. It is easy for machines to parse and generate.
39
40 JSON-GLib provides a parser and a generator GObject classes and various
41 wrappers for the complex data types employed by JSON, such as arrays
42 and objects.
43
44 JSON-GLib uses GLib native data types and the generic value container
45 GValue for ease of development. It also provides integration with the
46 GObject classes for direct serialization into, and deserialization from,
47 JSON data streams.
48
49 This package provides the GObject Introspection bindings for JSON-GLib.
50
51 %package devel
52 Summary:        Library for JavaScript Object Notation format - Development Files
53 Group:          System/Libraries
54 Requires:       json-glib = %{version}
55 %if %{with introspection}
56 Requires:       typelib-Json = %{version}
57 %endif
58 BuildRequires:  gettext
59
60 %description devel
61 JSON is a lightweight data-interchange format.It is easy for humans to
62 read and write. It is easy for machines to parse and generate.
63
64 JSON-GLib provides a parser and a generator GObject classes and various
65 wrappers for the complex data types employed by JSON, such as arrays
66 and objects.
67
68 JSON-GLib uses GLib native data types and the generic value container
69 GValue for ease of development. It also provides integration with the
70 GObject classes for direct serialization into, and deserialization from,
71 JSON data streams.
72
73 This package contains development files needed to develop with the
74 json-glib library.
75
76 %lang_package
77 %prep
78 %setup -q
79 cp %{SOURCE1001} .
80
81 %build
82 NOCONFIGURE=1
83 %reconfigure --disable-man --disable-doc
84 make %{?_smp_mflags}
85
86 %install
87 %make_install
88 %find_lang %{name}-1.0
89
90 mv %{name}-1.0.lang %{name}.lang
91
92 %post -n json-glib -p /sbin/ldconfig
93
94 %postun -n json-glib -p /sbin/ldconfig
95
96 %files
97 %manifest %{name}.manifest
98 %defattr(-,root,root)
99 %doc COPYING
100 %{_libdir}/*.so.*
101 %{_bindir}/*
102
103 %if %{with introspection}
104 %files -n typelib-Json
105 %manifest %{name}.manifest
106 %defattr(-,root,root)
107 %{_libdir}/girepository-1.0/Json-1.0.typelib
108 %endif
109
110 %files devel
111 %manifest %{name}.manifest
112 %defattr(-,root,root)
113 %{_includedir}/%{name}-1.0
114 %{_libdir}/*.so
115 %{_libdir}/pkgconfig/*.pc
116 %if %{with introspection}
117 %{_datadir}/gir-1.0/*.gir
118 %endif
119
120 %changelog