migration from private to rsa
[external/insserv.git] / packaging / insserv.spec
1 #sbs-git:slp/pkgs/i/insserv insserv 1.12.0 4a5235dc3ec71a9c5267734a3559387b181a17ed
2 Name: insserv
3 License: GPL v2 or later
4 Group: System/Base
5 Provides: /sbin/insserv
6 Version: 1.12.0
7 Release: 1
8 Summary: A Program to Arrange Initialization Scripts
9
10 Source0: insserv-%{version}.tar.gz
11 Source1: devfsd
12 Source2: hotplug
13 Source3: hotplug-net
14 Source4: initrd-tools.sh
15 Source5: modutils
16 Source6: check-initd-order
17 Source7: check-archive-initd-scripts
18 Source8: seq-changes
19 Source9: make-testsuite
20 Source10: update-bootsystem-insserv
21 Source11: update-rc.d-insserv
22 Source12: bash-completion
23
24 Patch0: 10_nosuse.patch
25 Patch1: 11_debian_conf.patch
26 Patch2: 20_install_perms_fixup.patch
27 Patch3: 21_tests_suite_new_functions.patch
28 Patch4: 30_deterministic_order.patch
29 Patch5: 40_badboy_segfault.patch
30 Patch6: 50_symlink_in_initddir.patch
31 Patch7: 61_interactive_keyword.patch
32 Patch8: 62_upstart_job.patch
33 Patch9: 70_req_start_all_depends.patch 
34 Patch10: 71_complete_makefile.patch
35 Patch11: 81_lessverbose.patch
36 Patch12: 82_loop_exit_msg.patch
37 Patch13: 91_kfreebsd_nofadvice.patch
38 Patch14: 92_m68k_alignment.patch
39 Patch15: 93_hurd_no_path_max.patch
40 Patch16: 94_v1_12_2.patch
41 Patch17: 95_stop_all.patch
42 Patch18: 96_hurd_no_at_funcs.patch
43
44 %description
45 Insserv enables an installed system init script (boot script) by
46 reading the comment header of the script and calculating the
47 dependencies between all scripts.
48
49
50 %prep
51 %setup
52
53 %patch0 -p1 -b .10_nosuse
54 %patch1 -p1 -b .11_debian_conf.patch
55 %patch2 -p1 -b .20_install_perms_fixup.patch
56 %patch3 -p1 -b .21_tests_suite_new_functions.patch
57 %patch4 -p1 -b .30_deterministic_order.patch
58 %patch5 -p1 -b .40_badboy_segfault.patch
59 %patch6 -p1 -b .50_symlink_in_initddir.patch
60 %patch7 -p1 -b .61_interactive_keyword.patch
61 %patch8 -p1 -b .62_upstart_job.patch
62 %patch9 -p1 -b .70_req_start_all_depends.patch
63 %patch10 -p1 -b .71_complete_makefile.patch
64 %patch11 -p1 -b .81_lessverbose.patch
65 %patch12 -p1 -b .82_loop_exit_msg.patch
66 %patch13 -p1 -b .91_kfreebsd_nofadvice.patch
67 %patch14 -p1 -b .92_m68k_alignment.patch
68 %patch15 -p1 -b .93_hurd_no_path_max.patch
69 %patch16 -p1 -b .94_v1_12_2.patch
70 %patch17 -p1 -b .95_stop_all.patch
71 %patch18 -p1 -b .96_hurd_no_at_funcs.patch
72
73
74 %build
75 make INITDIR=%{_sysconfdir}/init.d INSCONF=%{_sysconfdir}/insserv.conf
76
77 %install
78 make install DESTDIR=%{buildroot}
79
80 # Install overrides
81 install -d %{buildroot}/%{_datadir}/%{name}/overrides/
82 for src in %SOURCE1 %SOURCE2 %SOURCE3 %SOURCE4 %SOURCE5; do
83         install -m 644 $src %{buildroot}/%{_datadir}/%{name}/overrides/
84 done
85
86 # install
87 for src in %SOURCE6 %SOURCE7 %SOURCE8 %SOURCE9; do
88         install $src %{buildroot}/%{_datadir}/%{name}/
89 done
90
91 install -d %{buildroot}/%{_sbindir}
92 install %SOURCE10 %{buildroot}/%{_sbindir}/
93 install %SOURCE11 %{buildroot}/%{_sbindir}/
94
95 # Install bash(1) completion
96 install -d %{buildroot}/%{_sysconfdir}/bash_completion.d
97 install -m 644 %SOURCE12 %{buildroot}/%{_sysconfdir}/bash_completion.d/insserv
98
99 install -d %{buildroot}/var/lib/update-rc.d %{buildroot}/%{_sysconfdir}/insserv.conf.d
100
101 %files
102 %defattr(-,root,root)
103 %config %{_sysconfdir}/%{name}.conf
104 /sbin/insserv
105 %{_sbindir}/*
106 %{_datadir}/%{name}/*
107 %{_mandir}/man8/insserv.8.gz
108 %dir /var/lib/update-rc.d
109 %dir %{_sysconfdir}/insserv.conf.d
110 %{_sysconfdir}/bash_completion.d/insserv