Fix the lib path
[external/gupnp.git] / packaging / gupnp.spec
1 Name: gupnp
2 Version: 0.14.1_7
3 Release: 1
4 Summary: GUPNP
5 Group: <group>/<group>
6 License: LGPL v2
7 URL: http://www.gupnp.org/
8 Source0: %{name}-%{version}.tar.gz
9 Patch1: missed_service_node_bug.patch
10 BuildRequires:  pkgconfig(glib-2.0) >= 2.18
11 BuildRequires:  pkgconfig(gobject-2.0) >= 2.18
12 BuildRequires:  pkgconfig(gmodule-2.0)
13 BuildRequires:  pkgconfig(gssdp-1.0) >= 0.7.1
14 BuildRequires:  pkgconfig(libsoup-2.4) >= 2.4.1
15 BuildRequires:  pkgconfig(libxml-2.0)
16 # need dbus-glib-1 for use network-manager
17 BuildRequires:  pkgconfig(dbus-glib-1) >= 0.76
18 BuildRequires:  pkgconfig(uuid)
19 BuildRequires:  pkgconfig(gthread-2.0)
20 BuildRequires:  autoconf >= 2.67
21 Requires: /sbin/ldconfig
22 %description
23 GUPnP is an object-oriented open source framework for creating UPnP devices and
24 control points, written in C using GObject and libsoup. The GUPnP API is
25 intended to be easy to use, efficient and flexible.
26
27 %package devel
28 Summary:    GUPNP (devel)
29 Group:      Development/Headers
30 Requires:   %{name} = %{version}-%{release}
31
32 %description devel
33 GUPnP is an object-oriented open source framework for creating UPnP devices and
34 control points, written in C using GObject and libsoup. The GUPnP API is
35 intended to be easy to use, efficient and flexible.
36
37 %prep  
38 %setup -q  
39 %patch1 -p1
40   
41 %build  
42 %configure --prefix=/usr --with-context-manager=network-manager
43   
44 make %{?jobs:-j%jobs}  
45   
46 %install  
47 rm -rf %{buildroot}  
48 %make_install
49 rm -rf %{buildroot}/usr/share/
50 mkdir -p %{buildroot}/usr/share/license
51 cp COPYING %{buildroot}/usr/share/license/%{name}
52
53 %clean
54 rm -rf %{buildroot}
55
56 %post
57
58 %postun
59
60 %files
61 %defattr(-,root,root,-)
62 %doc
63 %{_libdir}/*.so.*
64 /usr/share/license/%{name}
65
66 %files devel
67 %defattr(-,root,root,-)
68 /usr/bin/gupnp-binding-tool
69 /usr/include/gupnp-1.0/*
70 #/usr/lib/*.a
71 %{_libdir}/*.so
72 %{_libdir}/pkgconfig/*
73