Cleaned up spec file including change of group, adding manifest file, style changes...
[external/byacc.git] / packaging / byacc.spec
1 %define byaccdate 20091027
2
3 Summary: Berkeley Yacc, a parser generator
4 Name: byacc
5 Version: 1.9.%{byaccdate}
6 Release: 2
7 License: Public Domain
8 Group: Platform Development/Building
9 URL: http://invisible-island.net/byacc/byacc.html
10 Source: %{name}-%{version}.tar.bz2
11 Source1001: packaging/byacc.manifest 
12
13 %description
14 Byacc (Berkeley Yacc) is a public domain LALR parser generator which
15 is used by many programs during their build process.
16
17 If you are going to do development on your system, you will want to install
18 this package.
19
20 %prep
21 %setup -q
22
23 %build
24 cp %{SOURCE1001} .
25 %configure --disable-dependency-tracking
26 make %{?jobs:-j%jobs}
27
28 %install
29 %make_install
30 ln -s yacc %{buildroot}/%{_bindir}/byacc
31 ln -s yacc.1 %{buildroot}/%{_mandir}/man1/byacc.1
32
33 %check
34 echo ====================TESTING=========================
35 make check
36 echo ====================TESTING END=====================
37
38 %clean
39 rm -rf %{buildroot}
40
41 %files
42 %doc ACKNOWLEDGEMENTS CHANGES NEW_FEATURES NOTES NO_WARRANTY README
43 %defattr(-,root,root,-)
44 %{_bindir}/yacc
45 %{_bindir}/byacc
46 %{_mandir}/man1/yacc.1*
47 %{_mandir}/man1/byacc.1*
48