1188e670ba3e2e50e994d77a252baa303880669d
[external/busybox.git] / util-linux / debian / patches / strip.patch
1 --- a/Makefile
2 +++ b/Makefile
3 @@ -690,20 +690,10 @@
4  endif # ifdef CONFIG_KALLSYMS
5  
6  # busybox image - including updated kernel symbols
7 -busybox_unstripped: $(busybox-all) FORCE
8 +busybox: $(busybox-all) FORCE
9         $(call if_changed_rule,busybox__)
10         $(Q)rm -f .old_version
11  
12 -busybox: busybox_unstripped
13 -ifeq ($(SKIP_STRIP),y)
14 -       $(Q)cp $< $@
15 -else
16 -       $(Q)$(STRIP) -s --remove-section=.note --remove-section=.comment \
17 -               busybox_unstripped -o $@
18 -# strip is confused by PIE executable and does not set exec bits
19 -       $(Q)chmod a+x $@
20 -endif
21 -
22  # The actual objects are generated when descending,
23  # make sure no implicit rule kicks in
24  $(sort $(busybox-all)): $(busybox-dirs) ;