packaging: also support rpmbuild from Tizen:2.3
[contrib/mraa.git] / packaging / mraa.spec
1 Name:           mraa
2 Version:        0.9.0
3 Release:        0
4 License:        MIT
5 Summary:        Low Level Skeleton Library for Communication
6 Url:            https://github.com/intel-iot-devkit/mraa
7 # X-Vc-Url:     https://github.com/intel-iot-devkit/mraa
8 Group:          Contrib
9 Source:         %{name}-%{version}.tar.gz
10
11 BuildRequires:  cmake
12 BuildRequires:  fdupes
13 BuildRequires:  python
14
15 %description
16 C/C++ library with bindings to javascript & python to interface
17 with the IO on Galileo, Edison & other platforms, with a structured and sane
18 API where port names/numbering matches the board that you are on.
19
20
21 %package devel
22 Summary:    Low Level Skeleton Library for Communication -- developer files
23 Group:      Contrib
24 Requires:   %{name} = %{version}-%{release}
25
26 %description devel
27 C/C++ library with bindings to javascript & python to interface
28 with the IO on Galileo, Edison & other platforms, with a structured and sane
29 API where port names/numbering matches the board that you are on.
30 Developer files.
31
32
33 %prep
34 %setup -q
35
36
37 %build
38
39 %cmake . \
40  -DCMAKE_INSTALL_PREFIX:PATH=/usr
41
42 %__make %{?_smp_mflags}
43
44
45 %install
46 %make_install
47 rm -rfv %{buildroot}%{_datadir}/%{name}/examples/
48 %fdupes %{buildroot}
49
50 %post -p /sbin/ldconfig
51
52 %postun -p /sbin/ldconfig
53
54
55 %files
56 %defattr(-,root,root)
57 %{_libdir}/*.so.*
58
59 %files devel
60 %defattr(-,root,root,-)
61 %{_includedir}/%{name}.h*
62 %{_includedir}/%{name}/*.h*
63 %{_libdir}/*.so
64 %{_libdir}/pkgconfig/%{name}.pc