0b393f7163235abe1c383838c2cbb7d176188a7d
[contrib/mraa.git] / packaging / mraa.spec
1 Name:           mraa
2 Version:        0.5.4
3 Release:        0
4 License:        MIT
5 Summary:        Low Level Skeleton Library for Communication
6 Url:            https://github.com/intel-iot-devkit/mraa
7 # X-Vc-Url:     https://github.com/intel-iot-devkit/mraa
8 Group:          Contrib
9 Source:         %{name}-%{version}.tar.gz
10
11 BuildRequires:  cmake
12 BuildRequires:  fdupes
13
14 %description
15 C/C++ library with bindings to javascript & python to interface
16 with the IO on Galileo, Edison & other platforms, with a structured and sane
17 API where port names/numbering matches the board that you are on.
18
19
20 %package devel
21 Summary:    Low Level Skeleton Library for Communication -- developer files
22 Group:      Contrib
23 Requires:   %{name} = %{version}-%{release}
24
25 %description devel
26 C/C++ library with bindings to javascript & python to interface
27 with the IO on Galileo, Edison & other platforms, with a structured and sane
28 API where port names/numbering matches the board that you are on.
29 Developer files.
30
31
32 %prep
33 %setup -q
34
35
36 %build
37
38 %cmake . \
39  -DCMAKE_INSTALL_PREFIX:PATH=/usr
40
41 %__make %{?_smp_mflags}
42
43
44 %install
45 %make_install
46 %fdupes %{buildroot}
47
48 %post -p /sbin/ldconfig
49
50 %postun -p /sbin/ldconfig
51
52
53 %files
54 %defattr(-,root,root)
55 %{_libdir}/*.so.*
56
57 %files devel
58 %defattr(-,root,root,-)
59 %{_includedir}/%{name}.h*
60 %{_includedir}/%{name}/*.h*
61 %{_libdir}/*.so
62 %{_libdir}/pkgconfig/%{name}.pc
63 %exclude %{_datadir}/%{name}/examples/