Packaging tpk file to rpm file
[archive/20210428/apps/native/smartthings-thing-service.git] / packaging / smartthings-thing-service.spec
1 Name:       smartthings-thing-service
2 Summary:    SmartThings Thing service app
3 Version:    1.0.0
4 Release:    1
5 Group:      Applications
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires:  pkgconfig(libtzplatform-config)
10 Requires(post):  /usr/bin/tpk-backend
11
12 %define preload_tpk_path %{TZ_SYS_RO_APP}/.preload-tpk
13
14 %description
15 This is a container package which has a preload TPK file
16
17 %prep
18 %setup -q
19
20 %build
21
22 %install
23 rm -rf %{buildroot}
24 mkdir -p %{buildroot}%{preload_tpk_path}
25 install org.tizen.st-things-service-1.0.0-arm.tpk %{buildroot}%{preload_tpk_path}/
26
27 %files
28 %defattr(-,root,root,-)
29 %{preload_tpk_path}/*.tpk
30