The download UI application is added.
[apps/web/download-manager.git] / packaging / org.tizen.download-manager.spec
1
2 Name:   org.tizen.download-manager
3 Summary:        Application for support of the content download
4 Version:        0.0.1
5 Release:        4
6 Group:          TO_BE_FILLED_IN
7 License:        TO_BE_FILLED_IN
8 URL:            N/A
9 Source0:        %{name}-%{version}.tar.gz
10 BuildRequires: pkgconfig(capi-web-url-download)
11 BuildRequires: pkgconfig(capi-system-runtime-info)
12 BuildRequires: pkgconfig(capi-appfw-application)
13 BuildRequires: pkgconfig(capi-network-connection)
14 BuildRequires: pkgconfig(capi-content-media-content)
15 BuildRequires: pkgconfig(elementary)
16 BuildRequires: pkgconfig(aul)
17 BuildRequires: pkgconfig(ecore)
18 BuildRequires: pkgconfig(bundle)
19 BuildRequires: pkgconfig(xdgmime)
20 BuildRequires: pkgconfig(icu-i18n)
21 BuildRequires: cmake
22 BuildRequires: gettext-devel
23 BuildRequires: expat-devel
24 BuildRequires: edje-tools
25
26 %description
27 Application for support of the content download
28
29 %prep
30 %setup -q
31
32 %build
33 cmake . -DCMAKE_INSTALL_PREFIX="/opt/apps/org.tizen.download-manager"
34
35 make %{?jobs:-j%jobs}
36
37 %install
38 rm -rf %{buildroot}
39 %make_install
40
41 %post
42 #### Download History ####
43 if [ ! -f /opt/apps/org.tizen.download-manager/data/db/.download-history.db ];
44 then
45                 sqlite3 /opt/apps/org.tizen.download-manager/data/db/.download-history.db 'PRAGMA journal_mode=PERSIST;
46                 create table history(id integer primary key autoincrement, historyid integer, downloadtype integer, contenttype integer, state integer, err integer, name, path, url, cookie, date datetime);'
47 fi
48
49 chown -R 5000:5000 /opt/apps/org.tizen.download-manager/data
50 chmod 660 /opt/apps/org.tizen.download-manager/data/db/.download-history.db
51 chmod 660 /opt/apps/org.tizen.download-manager/data/db/.download-history.db-journal
52
53 %files
54 %defattr(-,root,root,-)
55 /opt/apps/org.tizen.download-manager/bin/*
56 /opt/apps/org.tizen.download-manager/data
57 /opt/apps/org.tizen.download-manager/res/*
58 /opt/share/packages/org.tizen.download-manager.xml
59
60 %changelog
61 * Mon Aug 17 2012 Jungki Kwak <jungki.kwak@samsung.com>
62 - Add https protocol to service uri field
63
64 * Mon Aug 16 2012 Jungki Kwak <jungki.kwak@samsung.com>
65 - Change boilerplates and licence to flora
66
67 * Mon Aug 10 2012 Jungki Kwak <jungki.kwak@samsung.com>
68 - Do not display installing message
69
70 * Fri Aug 03 2012 Jungki Kwak <jungki.kwak@samsung.com>
71 - Initial release
72