7a6a06e20ab0f3ba45f7adbec8ca5fa7731485f0
[apps/osp/Gallery.git] / packaging / apps.Gallery.spec
1 Name:       apps.Gallery
2 Summary:    Gallery application
3 Version:    1.0.0
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(osp-appfw)
10 BuildRequires:  pkgconfig(osp-content)
11 BuildRequires:  pkgconfig(osp-image)
12 BuildRequires:  pkgconfig(osp-image-core)
13 BuildRequires:  pkgconfig(osp-locations)
14 BuildRequires:  pkgconfig(osp-media)
15 BuildRequires:  pkgconfig(osp-net)
16 BuildRequires:  pkgconfig(osp-uifw)
17 BuildRequires:  osp-appfw-internal-devel
18 BuildRequires:  osp-image-internal-devel
19 BuildRequires:  osp-media-internal-devel
20 BuildRequires:  osp-net-internal-devel
21 BuildRequires:  osp-uifw-internal-devel
22
23 Requires: osp-installer
24
25 %description
26 Verification application: Gallery
27
28 %prep
29 %setup -q
30
31 %build
32 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
33 %ifarch %{ix86}
34 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
35 %else
36 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
37 %endif
38
39 # Call make instruction with smp support
40 make %{?jobs:-j%jobs}
41
42 %install
43 rm -rf %{buildroot}
44 %make_install
45
46 %post
47 /sbin/ldconfig
48 PKG_ID=ijudt7w61q
49 echo "/usr/etc/package-manager/backend/tpk -i /usr/apps/"${PKG_ID}
50 /usr/etc/package-manager/backend/tpk -i /usr/apps/${PKG_ID}
51 cp -f /usr/lib/osp/osp-ui-app-loader /usr/apps/${PKG_ID}/bin/Gallery
52
53 %postun
54 /sbin/ldconfig
55 PKG_ID=ijudt7w61q
56 echo "/usr/etc/package-manager/backend/tpk -u "${PKG_ID}
57 /usr/etc/package-manager/backend/tpk -u ${PKG_ID}
58
59 %files
60 %defattr(-,root,root,-)
61 /usr/apps/*