9f37edeebb377239ed00b6051d7974b2556cdc96
[apps/osp/Call.git] / packaging / apps.Call.spec
1 Name:       apps.Call
2 Summary:    Call application
3 Version:    1.0.0.0
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(osp-appfw)
10 BuildRequires:  pkgconfig(osp-uifw)
11 BuildRequires:  pkgconfig(osp-social)
12 BuildRequires:  pkgconfig(osp-messaging)
13 BuildRequires:  pkgconfig(osp-media)
14 BuildRequires:  pkgconfig(osp-image)
15 BuildRequires:  pkgconfig(osp-image-core)
16 BuildRequires:  pkgconfig(osp-shell)
17 BuildRequires:  pkgconfig(osp-telephony)
18 BuildRequires:  pkgconfig(glib-2.0)
19 BuildRequires:  pkgconfig(capi-media-sound-manager)
20 BuildRequires:  pkgconfig(vconf)
21 BuildRequires:  pkgconfig(tapi)
22 BuildRequires:  pkgconfig(mm-sound)
23 BuildRequires:  pkgconfig(contacts-service2)
24 BuildRequires:  osp-appfw-internal-devel
25 BuildRequires:  osp-uifw-internal-devel
26 BuildRequires:  osp-media-internal-devel
27
28  # runtime requires
29 Requires: osp-installer
30
31 %description
32 Verification application: Call
33
34 %prep
35 %setup -q
36
37 %build
38 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
39 %ifarch %{ix86}
40 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
41 %else
42 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
43 %endif
44
45 # Call make instruction with smp support
46 make %{?jobs:-j%jobs}
47
48 %install
49 rm -rf %{buildroot}
50 %make_install
51
52 %post
53 /sbin/ldconfig
54 PKG_ID=zktdpemtmw
55 echo "/usr/etc/package-manager/backend/tpk -i /usr/apps/"${PKG_ID}
56 /usr/etc/package-manager/backend/tpk -i /usr/apps/${PKG_ID}
57 cp -f /usr/lib/osp/osp-ui-app-loader /usr/apps/${PKG_ID}/bin/Call
58 /usr/bin/vconftool set -t int memory/call/state "0" -g 6521 -i -f
59
60 %postun
61 /sbin/ldconfig
62 PKG_ID=zktdpemtmw
63 echo "/usr/etc/package-manager/backend/tpk -u "${PKG_ID}
64 /usr/etc/package-manager/backend/tpk -u ${PKG_ID}
65
66 %files
67 %defattr(-,root,root,-)
68 /usr/apps/*