2e1f50d2874bd108a54bb722630c71c78d01f36e
[apps/native/ug-wifi-efl.git] / packaging / wifi-efl-ug.spec
1 Name:           wifi-efl-ug
2 Summary:        Wi-Fi UI Gadget for TIZEN
3 Version:        1.1.5
4 Release:        1
5 Group:          App/Network
6 License:        Flora-1.1
7 Source0:        %{name}-%{version}.tar.gz
8 Source1001: %{name}.manifest
9
10 BuildRequires:  cmake
11 BuildRequires:  edje-tools
12 BuildRequires:  gettext-tools
13 BuildRequires:  pkgconfig(appcore-efl)
14 BuildRequires:  pkgconfig(aul)
15 BuildRequires:  pkgconfig(capi-network-connection)
16 BuildRequires:  pkgconfig(capi-network-tethering)
17 BuildRequires:  pkgconfig(capi-network-wifi-manager)
18 BuildRequires:  pkgconfig(capi-system-info)
19 BuildRequires:  pkgconfig(capi-ui-efl-util)
20 BuildRequires:  pkgconfig(cert-svc-vcore)
21 BuildRequires:  pkgconfig(ecore)
22 BuildRequires:  pkgconfig(ecore-imf)
23 BuildRequires:  pkgconfig(ecore-input)
24 BuildRequires:  pkgconfig(efl-extension)
25 BuildRequires:  pkgconfig(elementary)
26 BuildRequires:  pkgconfig(feedback)
27 BuildRequires:  pkgconfig(glib-2.0)
28 BuildRequires:  pkgconfig(libxml-2.0)
29 BuildRequires:  pkgconfig(openssl1.1)
30 BuildRequires:  pkgconfig(sensor)
31 BuildRequires:  pkgconfig(ui-gadget-1)
32 Requires(post):         /sbin/ldconfig
33 requires(postun):       /sbin/ldconfig
34
35 %description
36 Wi-Fi UI Gadget
37
38 %package -n net.wifi-qs
39 Summary:    Wi-Fi System popup
40 Requires:   %{name} = %{version}
41
42 %description -n net.wifi-qs
43 Wi-Fi System popup for TIZEN
44
45 %prep
46 %setup -q
47 cp %{SOURCE1001} ./%{name}.manifest
48
49 %build
50 %cmake . -DCMAKE_VERBOSE_MAKEFILE=OFF \
51         -DBIN_INSTALL_DIR:PATH=%{_bindir} \
52         -DAPP_INSTALL_DIR:PATH=%{TZ_SYS_RO_APP} \
53         -DUG_DIR_PREFIX:PATH=%{TZ_SYS_RO_UG} \
54         -DTIZEN_TETHERING_ENABLE=1 \
55         -DMODEL_BUILD_FEATURE_WLAN_CONCURRENT_MODE=1 \
56         -DTIZEN_MOBILE=1
57
58 make %{?_smp_mflags}
59
60 %install
61 %make_install
62
63 %post
64 /sbin/ldconfig
65 mkdir -p %{TZ_SYS_RO_APP}/%{name}/bin/
66
67 %postun -p /sbin/ldconfig
68
69 %files
70 %manifest %{name}.manifest
71 %{TZ_SYS_RO_UG}/lib/*
72 %{TZ_SYS_RO_APP}/%{name}/res/edje/*.edj
73 %{_datadir}/packages/%{name}.xml
74 %{_datadir}/locale/*/LC_MESSAGES/*.mo
75 %{_datadir}/icons/*.png
76 %{TZ_SYS_RO_APP}/%{name}/shared/res/tables/ug-wifi-efl_ChangeableColorTable.xml
77 %{TZ_SYS_RO_APP}/%{name}/shared/res/tables/ug-wifi-efl_FontInfoTable.xml
78 %license LICENSE
79
80 %files -n net.wifi-qs
81 %manifest %{name}.manifest
82 %{_bindir}/wifi-qs
83 %{_datadir}/packages/net.wifi-qs.xml
84 %{_datadir}/icons/*.png
85 %{TZ_SYS_RO_APP}/net.wifi-qs/res/edje/*.edj
86 %license LICENSE