Cellular connection state is separated to AVAILABLE and CONNECTED
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
1 %define _usrdir /usr
2 %define _ugdir  %{_usrdir}/ug
3
4 Name:       ug-setting-mobileap-efl
5 Summary:    Tethering UI Gadget Library
6 Version:    0.1.157
7 Release:    1
8 Group:      TO_BE/FILLED_IN
9 License:    Flora License Version 1.0
10 Source0:    %{name}-%{version}.tar.gz
11 Requires(post): /usr/bin/vconftool
12 BuildRequires: cmake
13 BuildRequires: gettext-tools
14 BuildRequires: pkgconfig(elementary)
15 BuildRequires: pkgconfig(evas)
16 BuildRequires: pkgconfig(ui-gadget-1)
17 BuildRequires: pkgconfig(wifi-direct)
18 BuildRequires: pkgconfig(capi-network-tethering)
19 BuildRequires: pkgconfig(capi-network-connection)
20 BuildRequires: pkgconfig(capi-network-wifi)
21 BuildRequires: pkgconfig(capi-telephony-sim)
22
23 %description
24 Tethering UI Gadget Library
25
26 %prep
27 %setup -q
28
29 %build
30 cmake . -DCMAKE_INSTALL_PREFIX="%{_ugdir}"
31 make %{?jobs:-j%jobs}
32
33 %install
34 rm -rf %{buildroot}
35 %make_install
36
37 %post
38 /usr/bin/vconftool set -t bool db/private/libug-setting-mobileap-efl/prev_wifi_status 0 -u 5000 -f
39
40 %files
41 %manifest ug-setting-mobileap-efl.manifest
42 %defattr(-,root,root,-)
43 %{_ugdir}/res/images/ug-mobile-ap/*.png
44 %{_ugdir}/res/locale/*/LC_MESSAGES/*
45 %{_ugdir}/lib/libug-setting-mobile-ap-ug.so
46
47 %changelog
48 * Mon Nov 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.157-1
49 - Cellular network state is separated to CONNECTION_CELLULAR_STATE_AVAILABLE and CONNECTION_CELLULAR_STATE_CONNECTED
50
51 * Wed Oct 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-2
52 - Initial package upload
53
54 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-1
55 - Install path is changed from /opt to /usr
56
57 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.155-1
58 - License is added
59
60 * Thu Oct 04 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.154-1
61 - Connection / Wi-Fi's changed CAPIs are applied
62
63 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.153-1
64 - Pop-up button's style is changed
65
66 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.152-1
67 - Add manifest file for SMACK
68
69 * Wed Aug 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.151-1
70 - When client's connection is changed, old handles are freed
71
72 * Wed Aug 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.150-1
73 - Managed APIs are used to get Network connection state and control Wi-Fi
74 - Crash issue is fixed because of "Unable to use tethering" pop-up
75 - End separator is added to each genlist
76 - Wi-Fi direct is considered when Wi-Fi tethering is enabled
77
78 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.149-1
79 - Managed APIs are used to get Wi-Fi tethering settings
80 - Password entry issue("Enter" can be inserted) is fixed
81
82 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-2
83 - Unused resource is removed
84
85 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-1
86 - Apply White theme
87
88 * Wed Jul 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-2
89 - Upload pkg for ug library change
90
91 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-1
92 - ui-gadget-1 is applied
93 - typedef struct rule is fixed
94 - unnecessary dependency and header include are removed
95
96 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.146-1
97 - library is stripped
98
99 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.145-1
100 - "Wi-Fi tethering is not enabled" issue is fixed
101
102 * Fri Jun 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.144-1
103 - libmobile-ap is replaced with capi-network-tethering
104
105 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.143-1
106 - Data usage is got from agent
107
108 * Thu Jun 04 2012 Injun Yang <injun.yang@samsung.com> 0.1.142-1
109 - Initialize vconf key
110 - Remove unused vconf key
111
112 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.141-1
113 - Enabled indicatons are handled
114 - Wi-Fi vconf is used to know when Wi-Fi is disabled
115 - Code clean-up
116
117 * Thu May 24 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.140-1
118 - hide option vconfkey is exported to internal vconfkeys
119
120 * Fri May 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.139-1
121 - "Tethering" translation data is applied
122
123 * Thu May 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.138-1
124 - Private vconfkey is changed following new naming rule
125
126 * Mon Mar 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.137-1
127 - Tethering and portable hotspot is changed to Tethering
128
129 * Tue Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.135-1
130 - libmobile-ap API's and EFL are changed
131
132 * Wed Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.130-1
133 - Deprecated dependencies are removed