Tethering: Add build requirement for bluetooth capi
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
1 %define _usrdir /usr
2 %define _ugdir  %{_usrdir}/ug
3
4 Name:       ug-setting-mobileap-efl
5 Summary:    Tethering UI Gadget Library
6 Version:    0.1.165
7 Release:    1
8 Group:      TO_BE/FILLED_IN
9 License:    Flora License Version 1.0
10 Source0:    %{name}-%{version}.tar.gz
11 Requires(post): /usr/bin/vconftool
12 BuildRequires: cmake
13 BuildRequires: edje-bin
14 BuildRequires: gettext-tools
15 BuildRequires: pkgconfig(elementary)
16 BuildRequires: pkgconfig(evas)
17 BuildRequires: pkgconfig(ui-gadget-1)
18 BuildRequires: pkgconfig(wifi-direct)
19 BuildRequires: pkgconfig(capi-network-tethering)
20 BuildRequires: pkgconfig(capi-network-connection)
21 BuildRequires: pkgconfig(capi-network-wifi)
22 BuildRequires: pkgconfig(capi-telephony-sim)
23 BuildRequires: pkgconfig(capi-network-bluetooth)
24 BuildRequires: pkgconfig(notification)
25
26 %description
27 Tethering UI Gadget Library
28
29 %prep
30 %setup -q
31
32 %build
33 cmake . -DCMAKE_INSTALL_PREFIX="%{_ugdir}"
34 make %{?jobs:-j%jobs}
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39
40 %post
41 /usr/bin/vconftool set -t bool db/private/libug-setting-mobileap-efl/prev_wifi_status 0 -u 5000 -f
42 /usr/bin/vconftool set -t int memory/mobile_hotspot/wifi_state 0 -g 6519 -i -f
43 mkdir -p /usr/ug/bin/
44 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-mobileap-efl
45
46 %files
47 %manifest ug-setting-mobileap-efl.manifest
48 %defattr(-,root,root,-)
49 %{_ugdir}/res/edje/ug-setting-mobileap-efl/*.edj
50 %{_ugdir}/res/locale/*/LC_MESSAGES/*
51 %{_ugdir}/res/images/ug-setting-mobileap-efl/*.png
52 %{_ugdir}/lib/libug-setting-mobileap-efl.so
53 /usr/share/packages/ug-setting-mobileap-efl.xml
54
55 %changelog
56 * Tue Apr 09 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.162-1
57 - Maximum connection information is displayed
58 - Implement connection timer
59 - UX Change : Data usage and Connected device
60 - Change ug name & Support appsvc
61 - Translation data is updated
62
63 * Fri Mar 29 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.161-2
64 - Fix : The grouping of genlist item is wrong
65 - Back button position and Naviframe title visibility are changed
66 - Make grouping for genlist expanded item
67 - Editfield change is applied
68 - Ticker notification is implemented for passphrase entry
69 - Implement title slide
70 - Pop-up parent and entry's context menu allowance are changed
71
72 * Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.160-1
73 - Remove unrequired log
74
75 * Tue Jan 15 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.159-1
76 - Fix : When device is rotated, guide text is displayed short time
77 - Fix : Security / Hide items are disabled sometimes
78 - Translation data is updated
79 - Pop-up scenario for USB tethering is implemented
80 - IMF is hided by focus out
81 - Wi-Fi tethering is enabled without checking enable state
82
83 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.158-1
84 - New winset is applied and some bugs are fixed
85
86 * Mon Nov 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.157-1
87 - Cellular network state is separated to CONNECTION_CELLULAR_STATE_AVAILABLE and CONNECTION_CELLULAR_STATE_CONNECTED
88
89 * Wed Oct 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-2
90 - Initial package upload
91
92 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-1
93 - Install path is changed from /opt to /usr
94
95 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.155-1
96 - License is added
97
98 * Thu Oct 04 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.154-1
99 - Connection / Wi-Fi's changed CAPIs are applied
100
101 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.153-1
102 - Pop-up button's style is changed
103
104 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.152-1
105 - Add manifest file for SMACK
106
107 * Wed Aug 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.151-1
108 - When client's connection is changed, old handles are freed
109
110 * Wed Aug 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.150-1
111 - Managed APIs are used to get Network connection state and control Wi-Fi
112 - Crash issue is fixed because of "Unable to use tethering" pop-up
113 - End separator is added to each genlist
114 - Wi-Fi direct is considered when Wi-Fi tethering is enabled
115
116 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.149-1
117 - Managed APIs are used to get Wi-Fi tethering settings
118 - Password entry issue("Enter" can be inserted) is fixed
119
120 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-2
121 - Unused resource is removed
122
123 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-1
124 - Apply White theme
125
126 * Wed Jul 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-2
127 - Upload pkg for ug library change
128
129 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-1
130 - ui-gadget-1 is applied
131 - typedef struct rule is fixed
132 - unnecessary dependency and header include are removed
133
134 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.146-1
135 - library is stripped
136
137 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.145-1
138 - "Wi-Fi tethering is not enabled" issue is fixed
139
140 * Fri Jun 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.144-1
141 - libmobile-ap is replaced with capi-network-tethering
142
143 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.143-1
144 - Data usage is got from agent
145
146 * Thu Jun 04 2012 Injun Yang <injun.yang@samsung.com> 0.1.142-1
147 - Initialize vconf key
148 - Remove unused vconf key
149
150 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.141-1
151 - Enabled indicatons are handled
152 - Wi-Fi vconf is used to know when Wi-Fi is disabled
153 - Code clean-up
154
155 * Thu May 24 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.140-1
156 - hide option vconfkey is exported to internal vconfkeys
157
158 * Fri May 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.139-1
159 - "Tethering" translation data is applied
160
161 * Thu May 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.138-1
162 - Private vconfkey is changed following new naming rule
163
164 * Mon Mar 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.137-1
165 - Tethering and portable hotspot is changed to Tethering
166
167 * Tue Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.135-1
168 - libmobile-ap API's and EFL are changed
169
170 * Wed Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.130-1
171 - Deprecated dependencies are removed