Tizen 2.1 base
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
1 %define _usrdir /usr
2 %define _ugdir  %{_usrdir}/ug
3
4 Name:       ug-setting-mobileap-efl
5 Summary:    Tethering UI Gadget Library
6 Version:    0.1.160
7 Release:    1
8 Group:      TO_BE/FILLED_IN
9 License:    Flora License Version 1.0
10 Source0:    %{name}-%{version}.tar.gz
11 Requires(post): /usr/bin/vconftool
12 BuildRequires: cmake
13 BuildRequires: edje-bin
14 BuildRequires: gettext-tools
15 BuildRequires: pkgconfig(elementary)
16 BuildRequires: pkgconfig(evas)
17 BuildRequires: pkgconfig(ui-gadget-1)
18 BuildRequires: pkgconfig(wifi-direct)
19 BuildRequires: pkgconfig(capi-network-tethering)
20 BuildRequires: pkgconfig(capi-network-connection)
21 BuildRequires: pkgconfig(capi-network-wifi)
22 BuildRequires: pkgconfig(capi-telephony-sim)
23
24 %description
25 Tethering UI Gadget Library
26
27 %prep
28 %setup -q
29
30 %build
31 cmake . -DCMAKE_INSTALL_PREFIX="%{_ugdir}"
32 make %{?jobs:-j%jobs}
33
34 %install
35 rm -rf %{buildroot}
36 %make_install
37
38 %post
39 /usr/bin/vconftool set -t bool db/private/libug-setting-mobileap-efl/prev_wifi_status 0 -u 5000 -f
40
41 %files
42 %manifest ug-setting-mobileap-efl.manifest
43 %defattr(-,root,root,-)
44 %{_ugdir}/res/edje/ug-setting-mobile-ap-ug/*.edj
45 %{_ugdir}/res/locale/*/LC_MESSAGES/*
46 %{_ugdir}/lib/libug-setting-mobile-ap-ug.so
47
48 %changelog
49 * Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.160-1
50 - Remove unrequired log
51
52 * Tue Jan 15 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.159-1
53 - Fix : When device is rotated, guide text is displayed short time
54 - Fix : Security / Hide items are disabled sometimes
55 - Translation data is updated
56 - Pop-up scenario for USB tethering is implemented
57 - IMF is hided by focus out
58 - Wi-Fi tethering is enabled without checking enable state
59
60 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.158-1
61 - New winset is applied and some bugs are fixed
62
63 * Mon Nov 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.157-1
64 - Cellular network state is separated to CONNECTION_CELLULAR_STATE_AVAILABLE and CONNECTION_CELLULAR_STATE_CONNECTED
65
66 * Wed Oct 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-2
67 - Initial package upload
68
69 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-1
70 - Install path is changed from /opt to /usr
71
72 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.155-1
73 - License is added
74
75 * Thu Oct 04 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.154-1
76 - Connection / Wi-Fi's changed CAPIs are applied
77
78 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.153-1
79 - Pop-up button's style is changed
80
81 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.152-1
82 - Add manifest file for SMACK
83
84 * Wed Aug 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.151-1
85 - When client's connection is changed, old handles are freed
86
87 * Wed Aug 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.150-1
88 - Managed APIs are used to get Network connection state and control Wi-Fi
89 - Crash issue is fixed because of "Unable to use tethering" pop-up
90 - End separator is added to each genlist
91 - Wi-Fi direct is considered when Wi-Fi tethering is enabled
92
93 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.149-1
94 - Managed APIs are used to get Wi-Fi tethering settings
95 - Password entry issue("Enter" can be inserted) is fixed
96
97 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-2
98 - Unused resource is removed
99
100 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-1
101 - Apply White theme
102
103 * Wed Jul 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-2
104 - Upload pkg for ug library change
105
106 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-1
107 - ui-gadget-1 is applied
108 - typedef struct rule is fixed
109 - unnecessary dependency and header include are removed
110
111 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.146-1
112 - library is stripped
113
114 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.145-1
115 - "Wi-Fi tethering is not enabled" issue is fixed
116
117 * Fri Jun 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.144-1
118 - libmobile-ap is replaced with capi-network-tethering
119
120 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.143-1
121 - Data usage is got from agent
122
123 * Thu Jun 04 2012 Injun Yang <injun.yang@samsung.com> 0.1.142-1
124 - Initialize vconf key
125 - Remove unused vconf key
126
127 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.141-1
128 - Enabled indicatons are handled
129 - Wi-Fi vconf is used to know when Wi-Fi is disabled
130 - Code clean-up
131
132 * Thu May 24 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.140-1
133 - hide option vconfkey is exported to internal vconfkeys
134
135 * Fri May 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.139-1
136 - "Tethering" translation data is applied
137
138 * Thu May 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.138-1
139 - Private vconfkey is changed following new naming rule
140
141 * Mon Mar 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.137-1
142 - Tethering and portable hotspot is changed to Tethering
143
144 * Tue Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.135-1
145 - libmobile-ap API's and EFL are changed
146
147 * Wed Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.130-1
148 - Deprecated dependencies are removed