Build dependency err fix.
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
1 %define _usrdir /usr
2 %define _ugdir  %{_usrdir}/ug
3 %bcond_with x
4
5 Name:       ug-setting-mobileap-efl
6 Summary:    Tethering UI Gadget Library
7 Version:    0.1.165
8 Release:    1
9 Group:      TO_BE/FILLED_IN
10 License:    Flora License Version 1.0
11 Source0:    %{name}-%{version}.tar.gz
12 Requires(post): /usr/bin/vconftool
13 BuildRequires: cmake
14 BuildRequires: edje-bin
15 BuildRequires: gettext-tools
16 BuildRequires: pkgconfig(elementary)
17 BuildRequires: pkgconfig(evas)
18 BuildRequires: pkgconfig(ui-gadget-1)
19 BuildRequires: pkgconfig(wifi-direct)
20 BuildRequires: pkgconfig(capi-network-tethering)
21 BuildRequires: pkgconfig(capi-network-connection)
22 BuildRequires: pkgconfig(capi-network-wifi)
23 BuildRequires: pkgconfig(capi-telephony-sim)
24 BuildRequires: pkgconfig(capi-network-bluetooth)
25 BuildRequires: pkgconfig(notification)
26 %if %{with x}
27 BuildRequires: pkgconfig(x11)
28 %endif
29
30 %description
31 Tethering UI Gadget Library
32
33 %prep
34 %setup -q
35
36 %build
37 cmake . -DCMAKE_INSTALL_PREFIX="%{_ugdir}"
38 make %{?jobs:-j%jobs}
39
40 %install
41 rm -rf %{buildroot}
42 %make_install
43
44 %post
45 /usr/bin/vconftool set -t bool db/private/libug-setting-mobileap-efl/prev_wifi_status 0 -u 5000 -f
46 /usr/bin/vconftool set -t int memory/mobile_hotspot/wifi_state 0 -g 6519 -i -f
47 mkdir -p /usr/ug/bin/
48 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-mobileap-efl
49
50 %files
51 %manifest ug-setting-mobileap-efl.manifest
52 %defattr(-,root,root,-)
53 %{_ugdir}/res/edje/ug-setting-mobileap-efl/*.edj
54 %{_ugdir}/res/locale/*/LC_MESSAGES/*
55 %{_ugdir}/res/images/ug-setting-mobileap-efl/*.png
56 %{_ugdir}/lib/libug-setting-mobileap-efl.so
57 /usr/share/packages/ug-setting-mobileap-efl.xml
58
59 %changelog
60 * Tue Apr 09 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.162-1
61 - Maximum connection information is displayed
62 - Implement connection timer
63 - UX Change : Data usage and Connected device
64 - Change ug name & Support appsvc
65 - Translation data is updated
66
67 * Fri Mar 29 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.161-2
68 - Fix : The grouping of genlist item is wrong
69 - Back button position and Naviframe title visibility are changed
70 - Make grouping for genlist expanded item
71 - Editfield change is applied
72 - Ticker notification is implemented for passphrase entry
73 - Implement title slide
74 - Pop-up parent and entry's context menu allowance are changed
75
76 * Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.160-1
77 - Remove unrequired log
78
79 * Tue Jan 15 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.159-1
80 - Fix : When device is rotated, guide text is displayed short time
81 - Fix : Security / Hide items are disabled sometimes
82 - Translation data is updated
83 - Pop-up scenario for USB tethering is implemented
84 - IMF is hided by focus out
85 - Wi-Fi tethering is enabled without checking enable state
86
87 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.158-1
88 - New winset is applied and some bugs are fixed
89
90 * Mon Nov 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.157-1
91 - Cellular network state is separated to CONNECTION_CELLULAR_STATE_AVAILABLE and CONNECTION_CELLULAR_STATE_CONNECTED
92
93 * Wed Oct 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-2
94 - Initial package upload
95
96 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-1
97 - Install path is changed from /opt to /usr
98
99 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.155-1
100 - License is added
101
102 * Thu Oct 04 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.154-1
103 - Connection / Wi-Fi's changed CAPIs are applied
104
105 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.153-1
106 - Pop-up button's style is changed
107
108 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.152-1
109 - Add manifest file for SMACK
110
111 * Wed Aug 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.151-1
112 - When client's connection is changed, old handles are freed
113
114 * Wed Aug 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.150-1
115 - Managed APIs are used to get Network connection state and control Wi-Fi
116 - Crash issue is fixed because of "Unable to use tethering" pop-up
117 - End separator is added to each genlist
118 - Wi-Fi direct is considered when Wi-Fi tethering is enabled
119
120 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.149-1
121 - Managed APIs are used to get Wi-Fi tethering settings
122 - Password entry issue("Enter" can be inserted) is fixed
123
124 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-2
125 - Unused resource is removed
126
127 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-1
128 - Apply White theme
129
130 * Wed Jul 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-2
131 - Upload pkg for ug library change
132
133 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-1
134 - ui-gadget-1 is applied
135 - typedef struct rule is fixed
136 - unnecessary dependency and header include are removed
137
138 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.146-1
139 - library is stripped
140
141 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.145-1
142 - "Wi-Fi tethering is not enabled" issue is fixed
143
144 * Fri Jun 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.144-1
145 - libmobile-ap is replaced with capi-network-tethering
146
147 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.143-1
148 - Data usage is got from agent
149
150 * Thu Jun 04 2012 Injun Yang <injun.yang@samsung.com> 0.1.142-1
151 - Initialize vconf key
152 - Remove unused vconf key
153
154 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.141-1
155 - Enabled indicatons are handled
156 - Wi-Fi vconf is used to know when Wi-Fi is disabled
157 - Code clean-up
158
159 * Thu May 24 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.140-1
160 - hide option vconfkey is exported to internal vconfkeys
161
162 * Fri May 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.139-1
163 - "Tethering" translation data is applied
164
165 * Thu May 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.138-1
166 - Private vconfkey is changed following new naming rule
167
168 * Mon Mar 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.137-1
169 - Tethering and portable hotspot is changed to Tethering
170
171 * Tue Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.135-1
172 - libmobile-ap API's and EFL are changed
173
174 * Wed Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.130-1
175 - Deprecated dependencies are removed