895e556f3aacc5e87b5ee724705fe9d610291f03
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
1 %define _usrdir /usr
2 %define _ugdir  %{_usrdir}/ug
3 %bcond_with x
4
5 Name:       ug-setting-mobileap-efl
6 Summary:    Tethering UI Gadget Library
7 Version:    0.1.165
8 Release:    1
9 Group:      TO_BE/FILLED_IN
10 License:    Flora License Version 1.0
11 Source0:    %{name}-%{version}.tar.gz
12 Requires(post): /usr/bin/vconftool
13 BuildRequires: cmake
14 BuildRequires: edje-bin
15 BuildRequires: gettext-tools
16 BuildRequires: libtzplatform-config-devel
17 BuildRequires: pkgconfig(elementary)
18 BuildRequires: pkgconfig(evas)
19 BuildRequires: pkgconfig(ui-gadget-1)
20 BuildRequires: pkgconfig(wifi-direct)
21 BuildRequires: pkgconfig(capi-network-tethering)
22 BuildRequires: pkgconfig(capi-network-connection)
23 BuildRequires: pkgconfig(capi-network-wifi)
24 BuildRequires: pkgconfig(capi-telephony-sim)
25 BuildRequires: pkgconfig(capi-network-bluetooth)
26 BuildRequires: pkgconfig(notification)
27 %if %{with x}
28 BuildRequires: pkgconfig(x11)
29 %endif
30
31 %description
32 Tethering UI Gadget Library
33
34 %prep
35 %setup -q
36
37 %build
38 cmake . -DCMAKE_INSTALL_PREFIX="%{_ugdir}"
39 make %{?jobs:-j%jobs}
40
41 %install
42 rm -rf %{buildroot}
43 %make_install
44
45 %post
46 GID=$(getent group %{TZ_SYS_USER_GROUP} | cut -f 3 -d :)
47 /usr/bin/vconftool set -t bool db/private/libug-setting-mobileap-efl/prev_wifi_status 0 -g $GID -f
48 /usr/bin/vconftool set -t int memory/mobile_hotspot/wifi_state 0 -g 6519 -i -f
49 mkdir -p /usr/ug/bin/
50 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-mobileap-efl
51
52 %files
53 %manifest ug-setting-mobileap-efl.manifest
54 %defattr(-,root,root,-)
55 %{_ugdir}/res/edje/ug-setting-mobileap-efl/*.edj
56 %{_ugdir}/res/locale/*/LC_MESSAGES/*
57 %{_ugdir}/res/images/ug-setting-mobileap-efl/*.png
58 %{_ugdir}/lib/libug-setting-mobileap-efl.so
59 /usr/share/packages/ug-setting-mobileap-efl.xml
60
61 %changelog
62 * Tue Apr 09 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.162-1
63 - Maximum connection information is displayed
64 - Implement connection timer
65 - UX Change : Data usage and Connected device
66 - Change ug name & Support appsvc
67 - Translation data is updated
68
69 * Fri Mar 29 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.161-2
70 - Fix : The grouping of genlist item is wrong
71 - Back button position and Naviframe title visibility are changed
72 - Make grouping for genlist expanded item
73 - Editfield change is applied
74 - Ticker notification is implemented for passphrase entry
75 - Implement title slide
76 - Pop-up parent and entry's context menu allowance are changed
77
78 * Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.160-1
79 - Remove unrequired log
80
81 * Tue Jan 15 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.159-1
82 - Fix : When device is rotated, guide text is displayed short time
83 - Fix : Security / Hide items are disabled sometimes
84 - Translation data is updated
85 - Pop-up scenario for USB tethering is implemented
86 - IMF is hided by focus out
87 - Wi-Fi tethering is enabled without checking enable state
88
89 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.158-1
90 - New winset is applied and some bugs are fixed
91
92 * Mon Nov 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.157-1
93 - Cellular network state is separated to CONNECTION_CELLULAR_STATE_AVAILABLE and CONNECTION_CELLULAR_STATE_CONNECTED
94
95 * Wed Oct 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-2
96 - Initial package upload
97
98 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-1
99 - Install path is changed from /opt to /usr
100
101 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.155-1
102 - License is added
103
104 * Thu Oct 04 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.154-1
105 - Connection / Wi-Fi's changed CAPIs are applied
106
107 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.153-1
108 - Pop-up button's style is changed
109
110 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.152-1
111 - Add manifest file for SMACK
112
113 * Wed Aug 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.151-1
114 - When client's connection is changed, old handles are freed
115
116 * Wed Aug 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.150-1
117 - Managed APIs are used to get Network connection state and control Wi-Fi
118 - Crash issue is fixed because of "Unable to use tethering" pop-up
119 - End separator is added to each genlist
120 - Wi-Fi direct is considered when Wi-Fi tethering is enabled
121
122 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.149-1
123 - Managed APIs are used to get Wi-Fi tethering settings
124 - Password entry issue("Enter" can be inserted) is fixed
125
126 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-2
127 - Unused resource is removed
128
129 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-1
130 - Apply White theme
131
132 * Wed Jul 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-2
133 - Upload pkg for ug library change
134
135 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-1
136 - ui-gadget-1 is applied
137 - typedef struct rule is fixed
138 - unnecessary dependency and header include are removed
139
140 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.146-1
141 - library is stripped
142
143 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.145-1
144 - "Wi-Fi tethering is not enabled" issue is fixed
145
146 * Fri Jun 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.144-1
147 - libmobile-ap is replaced with capi-network-tethering
148
149 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.143-1
150 - Data usage is got from agent
151
152 * Thu Jun 04 2012 Injun Yang <injun.yang@samsung.com> 0.1.142-1
153 - Initialize vconf key
154 - Remove unused vconf key
155
156 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.141-1
157 - Enabled indicatons are handled
158 - Wi-Fi vconf is used to know when Wi-Fi is disabled
159 - Code clean-up
160
161 * Thu May 24 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.140-1
162 - hide option vconfkey is exported to internal vconfkeys
163
164 * Fri May 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.139-1
165 - "Tethering" translation data is applied
166
167 * Thu May 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.138-1
168 - Private vconfkey is changed following new naming rule
169
170 * Mon Mar 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.137-1
171 - Tethering and portable hotspot is changed to Tethering
172
173 * Tue Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.135-1
174 - libmobile-ap API's and EFL are changed
175
176 * Wed Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.130-1
177 - Deprecated dependencies are removed