Add multi-user support.
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
1 %define _usrdir /usr
2 %define _ugdir  %{_usrdir}/ug
3
4 Name:       ug-setting-mobileap-efl
5 Summary:    Tethering UI Gadget Library
6 Version:    0.1.165
7 Release:    1
8 Group:      TO_BE/FILLED_IN
9 License:    Flora License Version 1.0
10 Source0:    %{name}-%{version}.tar.gz
11 Requires(post): /usr/bin/vconftool
12 BuildRequires: cmake
13 BuildRequires: edje-bin
14 BuildRequires: gettext-tools
15 BuildRequires: libtzplatform-config-devel
16 BuildRequires: pkgconfig(elementary)
17 BuildRequires: pkgconfig(evas)
18 BuildRequires: pkgconfig(ui-gadget-1)
19 BuildRequires: pkgconfig(wifi-direct)
20 BuildRequires: pkgconfig(capi-network-tethering)
21 BuildRequires: pkgconfig(capi-network-connection)
22 BuildRequires: pkgconfig(capi-network-wifi)
23 BuildRequires: pkgconfig(capi-telephony-sim)
24 BuildRequires: pkgconfig(capi-network-bluetooth)
25 BuildRequires: pkgconfig(notification)
26
27 %description
28 Tethering UI Gadget Library
29
30 %prep
31 %setup -q
32
33 %build
34 cmake . -DCMAKE_INSTALL_PREFIX="%{_ugdir}"
35 make %{?jobs:-j%jobs}
36
37 %install
38 rm -rf %{buildroot}
39 %make_install
40
41 %post
42 GID=$(getent group %{TZ_SYS_USER_GROUP} | cut -f 3 -d :)
43 /usr/bin/vconftool set -t bool db/private/libug-setting-mobileap-efl/prev_wifi_status 0 -g $GID -f
44 /usr/bin/vconftool set -t int memory/mobile_hotspot/wifi_state 0 -g 6519 -i -f
45 mkdir -p /usr/ug/bin/
46 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-mobileap-efl
47
48 %files
49 %manifest ug-setting-mobileap-efl.manifest
50 %defattr(-,root,root,-)
51 %{_ugdir}/res/edje/ug-setting-mobileap-efl/*.edj
52 %{_ugdir}/res/locale/*/LC_MESSAGES/*
53 %{_ugdir}/res/images/ug-setting-mobileap-efl/*.png
54 %{_ugdir}/lib/libug-setting-mobileap-efl.so
55 /usr/share/packages/ug-setting-mobileap-efl.xml
56
57 %changelog
58 * Tue Apr 09 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.162-1
59 - Maximum connection information is displayed
60 - Implement connection timer
61 - UX Change : Data usage and Connected device
62 - Change ug name & Support appsvc
63 - Translation data is updated
64
65 * Fri Mar 29 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.161-2
66 - Fix : The grouping of genlist item is wrong
67 - Back button position and Naviframe title visibility are changed
68 - Make grouping for genlist expanded item
69 - Editfield change is applied
70 - Ticker notification is implemented for passphrase entry
71 - Implement title slide
72 - Pop-up parent and entry's context menu allowance are changed
73
74 * Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.160-1
75 - Remove unrequired log
76
77 * Tue Jan 15 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.159-1
78 - Fix : When device is rotated, guide text is displayed short time
79 - Fix : Security / Hide items are disabled sometimes
80 - Translation data is updated
81 - Pop-up scenario for USB tethering is implemented
82 - IMF is hided by focus out
83 - Wi-Fi tethering is enabled without checking enable state
84
85 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.158-1
86 - New winset is applied and some bugs are fixed
87
88 * Mon Nov 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.157-1
89 - Cellular network state is separated to CONNECTION_CELLULAR_STATE_AVAILABLE and CONNECTION_CELLULAR_STATE_CONNECTED
90
91 * Wed Oct 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-2
92 - Initial package upload
93
94 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-1
95 - Install path is changed from /opt to /usr
96
97 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.155-1
98 - License is added
99
100 * Thu Oct 04 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.154-1
101 - Connection / Wi-Fi's changed CAPIs are applied
102
103 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.153-1
104 - Pop-up button's style is changed
105
106 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.152-1
107 - Add manifest file for SMACK
108
109 * Wed Aug 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.151-1
110 - When client's connection is changed, old handles are freed
111
112 * Wed Aug 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.150-1
113 - Managed APIs are used to get Network connection state and control Wi-Fi
114 - Crash issue is fixed because of "Unable to use tethering" pop-up
115 - End separator is added to each genlist
116 - Wi-Fi direct is considered when Wi-Fi tethering is enabled
117
118 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.149-1
119 - Managed APIs are used to get Wi-Fi tethering settings
120 - Password entry issue("Enter" can be inserted) is fixed
121
122 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-2
123 - Unused resource is removed
124
125 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-1
126 - Apply White theme
127
128 * Wed Jul 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-2
129 - Upload pkg for ug library change
130
131 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-1
132 - ui-gadget-1 is applied
133 - typedef struct rule is fixed
134 - unnecessary dependency and header include are removed
135
136 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.146-1
137 - library is stripped
138
139 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.145-1
140 - "Wi-Fi tethering is not enabled" issue is fixed
141
142 * Fri Jun 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.144-1
143 - libmobile-ap is replaced with capi-network-tethering
144
145 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.143-1
146 - Data usage is got from agent
147
148 * Thu Jun 04 2012 Injun Yang <injun.yang@samsung.com> 0.1.142-1
149 - Initialize vconf key
150 - Remove unused vconf key
151
152 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.141-1
153 - Enabled indicatons are handled
154 - Wi-Fi vconf is used to know when Wi-Fi is disabled
155 - Code clean-up
156
157 * Thu May 24 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.140-1
158 - hide option vconfkey is exported to internal vconfkeys
159
160 * Fri May 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.139-1
161 - "Tethering" translation data is applied
162
163 * Thu May 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.138-1
164 - Private vconfkey is changed following new naming rule
165
166 * Mon Mar 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.137-1
167 - Tethering and portable hotspot is changed to Tethering
168
169 * Tue Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.135-1
170 - libmobile-ap API's and EFL are changed
171
172 * Wed Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.130-1
173 - Deprecated dependencies are removed